Dmitriy427

Пользователи
  • Публикаций

    85
  • Зарегистрирован

  • Посещение

  • Победитель дней

    2

Dmitriy427 стал победителем дня 20 мая 2016

Dmitriy427 имел наиболее популярный контент!

Информация о Dmitriy427

  • Звание
    Пользователь
  • День рождения

Информация

Посетители профиля

825 просмотров профиля
  1. Не знаю, что такое "интерфейс функции", даже про функции в ООП слышал только от тех самых "криворуких обезъян". Вижу, что добавили аргумент, в метод " _createMember " класса Members. На мой взгляд, это говорит о том что, в отличии от PHPBB, движок все ещё, развивается. Что до несовершенства документации... охшит, а покажите мне доки хоть одного командного проекта, где нет и не было подобных ляпов. И уж точно не "поклоннику PHBB" об этом не знать.
  2. Там все лишнее, не используются теги "<else>", "</else>" в логике шаблонов IPB 3, есть только "<else />".
  3. Проблема там была с кривым плагином "Adblock Detected", спойлер в норме.
  4. 1. Двойка нормально работает на PHP 5.3, проблемы там только с установкой и обработкой XML, решения есть в сети. Тут ссылку на сабж выпилили, поэтому гуглите "ipb 2 php 5.3", без кавычек. 2. Можно использовать разные версии PHP на одном сервере. Опять же - гугл в помощь. P.S. Добавлю, пожалуй, что статья на хабре, по настройке апача с mod_suphp - решение не лучшее из возможных.
  5. Там написано все, восстанавливайте битую таблицу "core_sessions". И остальные проверьте, где одна битая, там могут быть и другие. Причин может быть много, самая распространенная - шутдаун сервера или "горячая" (с работающими сайтами) перезагрузка mysql-server.
  6. В шаблоне IPB 3.x логика raw-php работать не будет. Используйте теги "<php>", "</php>". Если скрипт лежит в корневой папке IP.Board: {parse include="file.php"}
  7. А где там сторонний стиль админки? Что-то с хостингом, похоже.
  8. Смогу, но предпочел бы писать для 4.1.х. Пишите в личку.
  9. Плаги - парсер атачей-изображений для галереи сделать можно. Готовых не видел.
  10. Я не собираюсь бесконечно спорить с воинствующим профаном, это крайнее сообщение для Вас. Ошибка уровня E_WARNING может прервать работу функции, только если автор функции этого захотел.
  11. 1S111 - код ошибки. 1 - уровень ошибки (XML_ERR_WARNING).
  12. Ещё раз, могу по слогам, но уже в последний раз, говорю: Конкретно эта ошибка не может, сама по себе, прервать работу любого модуля libXML, включая ридер . Читайте доки - www.xmlsoft.org/html/libxml-xmlerror.html .
  13. Вы можете что угодно логически предполагать, а я просто знаю, поскольку с подобными ошибками уже встречался на практике. В новом фреймворке ips выполнение скрипта может быть прервано обычным E_WARNING из-за повсеместного применения конструкций вида: try{ ... } catch( \IPS\Class\Exception $e ) { return false; } Подавление ошибок такое развитие событий предотвращает, зачастую.
  14. Просмотр файла (DF41) Fix for Tags Search Фикс для системы поиска по тегам. Исправляет ошибку поиска по кириллическим тегам. Проверено для 4.1.7, 4.1.8. Добавил Dmitriy427 Добавлено 07.03.2016 Категория Интерфейс Язык Язык: Любой
  15. Конкретно эта ошибка разбор не прекратит, если используется "этот костыль", но очевидно она там не единственная. Безапеляционные заявления, при отсутствие ясного понимания причин проблемы, вам авторитета не добавят.