Jump to content
Sanshalay

Friendly URL Translit

Recommended Posts

Установила. Ссылки меняет на латиницу, но есть проблема: когда создаешь тему, нажимаешь "отправить тему" и появляется окно с ошибкой EX2.

Прочитала форум, прийдется переустанавливать русский язык.

Share this post


Link to post
Share on other sites

@Sipsb Не помогло :(

Чистила кеш через форму во вкладке Техническая поддержка. Не помогло.

Прочитала тему Код ошибки: EX2, проверила работоспособность на английском языке. То же самое.

Я так понимаю, что установив русский язык вновь, транслитерация не будет работать. Хотя можно попробовать.

Снимок экрана 2016-02-26 в 21.01.55.png

Снимок экрана 2016-02-26 в 21.03.59.png

Share this post


Link to post
Share on other sites

@soka Починила! Проблема была в другом! Ставила плагин tapatalk и видимо после установки данного произошло какое-то наложение. В итоге снесла tapatalk и все работает!

Хотя читала много форумов, включая забугорных. У многих проблемы разные. Чаще проблема кроится в кэшировании Memcached.

П.С.: можно зачистить здесь и перенести мои ответы в тему Код ошибки: EX2

Share this post


Link to post
Share on other sites
14 минут назад, iScream сказал:

Проблема была в другом!

Я разве где-то говорил в чем была проблема? Я просил вас привести логи, только по ним можно делать какие-то конкретные предположения.

 

14 минут назад, iScream сказал:

У многих проблемы разные.

Поэтому нужно смотреть логи.

 

15 минут назад, iScream сказал:

Чаще проблема кроится в кэшировании Memcached.

Не надо фантазировать. Это код всех критических ошибок которые возникают на форуме и абсолютно не корректно потому что это общесобирательная ошибка и не привязана к какой-то конкретной функции. Причину ее возникновения нужно смотреть только в логах.

Share this post


Link to post
Share on other sites

soka, благодарю за разъяснение! К сожалению нигде не было написано, что это ошибка общего формата и за ней может скрываться все, что угодно. В логах нашла причину.

Share this post


Link to post
Share on other sites
7 минут назад, iScream сказал:

В логах нашла причину.

Ну так нашла причину, напиши здесь, что другие не задавали лишних вопросов

Share this post


Link to post
Share on other sites
Только что, kgb сказал:

Ну так нашла причину, напиши здесь, что другие не задавали лишних вопросов

Я написала все выше специально, чтобы другие обратили на это внимание ;)

Share this post


Link to post
Share on other sites

После обновления плагина и сброса URL получаю вот это -

IPS\Http\Url\Exception: SEO_TEMPLATE_IS_NOT_VALID_FOR_URL (0)
#0 [internal function]: IPS\Http\Url\_Friendly::friendlyUrlFromQueryString('app=forums&modu...', 'forums_topic', Array, 0)
#1 /var/www/u0156839/data/www/forum.samp-grp.ru/init.php(442) : eval()'d code(67): call_user_func_array('parent::friendl...', Array)
#2 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Http/Url.php(85): IPS\Http\Url\cms_hook_FriendlyUrl::friendlyUrlFromQueryString('app=forums&modu...', 'forums_topic', Array, 0)
#3 /var/www/u0156839/data/www/forum.samp-grp.ru/applications/forums/sources/Forum/Forum.php(494): IPS\Http\_Url::internal('app=forums&modu...', 'front', 'forums_topic', Array)
#4 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Theme/Theme.php(734) : eval()'d code(599): IPS\forums\_Forum->lastPost()
#5 [internal function]: IPS\Theme\class_forums_front_index->forumRow(Object(IPS\forums\Forum))
#6 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Theme/SandboxedTemplate.php(57): call_user_func_array(Array, Array)
#7 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Theme/Theme.php(734) : eval()'d code(1388): IPS\Theme\_SandboxedTemplate->__call('forumRow', Array)
#8 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Theme/Theme.php(734) : eval()'d code(1388): IPS\Theme\SandboxedTemplate->forumRow(Object(IPS\forums\Forum))
#9 [internal function]: IPS\Theme\class_forums_front_index->index()
#10 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Theme/SandboxedTemplate.php(57): call_user_func_array(Array, Array)
#11 /var/www/u0156839/data/www/forum.samp-grp.ru/applications/forums/modules/front/forums/index.php(70): IPS\Theme\_SandboxedTemplate->__call('index', Array)
#12 /var/www/u0156839/data/www/forum.samp-grp.ru/applications/forums/modules/front/forums/index.php(70): IPS\Theme\SandboxedTemplate->index()
#13 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Dispatcher/Controller.php(96): IPS\forums\modules\front\forums\_index->manage()
#14 /var/www/u0156839/data/www/forum.samp-grp.ru/applications/forums/modules/front/forums/index.php(37): IPS\Dispatcher\_Controller->execute()
#15 /var/www/u0156839/data/www/forum.samp-grp.ru/system/Dispatcher/Dispatcher.php(129): IPS\forums\modules\front\forums\_index->execute()
#16 /var/www/u0156839/data/www/forum.samp-grp.ru/index.php(13): IPS\_Dispatcher->run()
#17 {main}

 

Share this post


Link to post
Share on other sites

Прогнал:

Цитата

UPDATE ipb_forums_topics SET title_seo='';
UPDATE ipb_forums_forums SET name_seo='';

Теперь по getLastComment ни чего не открывается, хотя в тему заходил и проверял что url в транслите создался. 

Как пофиксить? 

Share this post


Link to post
Share on other sites

На версии 4.1.15  установил плагин, новые темы создаются с латиницей, а старые так и остались по русски, как перестроить старые темы на латиницу??

Share this post


Link to post
Share on other sites
19 часов назад, Fader сказал:

будьте добры, sql-запрос для статей

UPDATE `PREFIXXXXXXX!!!!!_cms_custom_database_1` SET `record_dynamic_furl` = NULL;

Share this post


Link to post
Share on other sites

Интересует информация, для тегов и префиксов обязательно делать запрос sql,  так и остались на кириллице! Какой запрос по тегам и префиксам нужно делать!

Share this post


Link to post
Share on other sites
36 минут назад, TIR777 сказал:

Интересует информация, для тегов и префиксов обязательно делать запрос sql,  так и остались на кириллице! Какой запрос по тегам и префиксам нужно делать!

Ты вообще как себе транслитерцию тегов представляешь? С у четом того, что по тегам поиск осуществляется

Share this post


Link to post
Share on other sites
12 минут назад, Ректор сказал:

ребят, подскажите, поставил плагин, но в чате не работает

после установки плагина весь новый контент будет иметь другие ссылки, но не старый.  Изучайте 

Чат тут не причем 

Share this post


Link to post
Share on other sites
6 минут назад, Redneck сказал:

после установки плагина весь новый контент будет иметь другие ссылки, но не старый.  Изучайте 

Чат тут не причем 

ткните носом, если не сложно.

ведь плагин установлен и включен

Share this post


Link to post
Share on other sites
1 минуту назад, Ректор сказал:

ткните носом, если не сложно.

ведь плагин установлен и включен

Цитата

 Однако у этого плагина есть недостаток - он не конвертирует уже существующие ссылки, только новые. Чтобы исправить это, необходимо выполнить несколько простых запросов к вашей базе данных.

Для этого перейдите в Админцентр --> Система --> Поддержка --> Техническая поддержка. В правом блоке Системная информация нажмите на ссылку Инструменты SQL. В поле для ввода запроса, расположенное над таблицей, введите следующее и нажмите кнопку Выполнить запрос: Не забывайте указывать Ваш префикс таблиц БД  XXX__

 

Share this post


Link to post
Share on other sites
6 минут назад, Sipsb сказал:

Можно поставить этот 

 

Кстати, да

У меня Friendly URL Translit не заработал, одна из возможных причин - установленный Tapatalk

Установил Seo Транслитерация - все заработало как часы!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×