Jump to content
AUS

Создать Блок вывода последних статей в Блогах (с изображением)

Recommended Posts

Сори ребятки я наверное многим уже надоел тут :) но есть еще вопросик:

Вот сделал что бы название блога выходило с новой строки.
aut.JPG

А как сделать так что бы впереди появилось Блог: как перед Автор: не нарисовать, а обратится к переменной правильно

 

<span class='ipsType_blendLinks ipsType_light ipsType_medium ipsType_break ipsContained'>
{lang="byline_nodate" htmlsprintf="$entry->author()->link()"} 
{lang="in"} 
<br>
<a href='{$entry->container()->url()}' class='ipsType_blendLinks'>
{$entry->container()->_title}
</a>
</span>

 

Share this post


Link to post
Share on other sites

UPDATE: переменную нашел

<span class='ipsType_blendLinks ipsType_light ipsType_medium ipsType_break ipsContained'>
{lang="byline_nodate" htmlsprintf="$entry->author()->link()"} 
<br>
{lang="embed_blog"} 
<a href='{$entry->container()->url()}' class='ipsType_blendLinks'>{$entry->container()->_title}</a>
</span>

осталось понять как двоеточие добавить :$

Share this post


Link to post
Share on other sites

Ну вроде все, осталось отсеять попадание смайлов вместо картинки и всё будет в лучшем виде. 

-aut.JPG

Share this post


Link to post
Share on other sites

Косячек нашелся. Если одной статье выставили рейтинг то в виджете все отображаются с этим рейтингом. 
 

Share this post


Link to post
Share on other sites
В 13.07.2016 в 19:10, AUS сказал:

Косячек нашелся. Если одной статье выставили рейтинг то в виджете все отображаются с этим рейтингом. 
 

Народ помогите исправить 

 

Share this post


Link to post
Share on other sites
15 минут назад, AUS сказал:

После последнего обновления стал глючить этот блок  >:( 

Помогите разобраться почему он перестал работать на версии 4.1.16 что изменилось и как это исправить :( 

Share this post


Link to post
Share on other sites
В 22.10.2016 в 11:56, Quzask сказал:

Вывести бы такой блок с новостями. Возможно?

Что есть новости? )) Какой компонент?  

Share this post


Link to post
Share on other sites
В 28.10.2016 в 22:33, Quzask сказал:

http://your-vr.ru/news/

База данных насколько я понимаю?

Понятия не имею как ты создал эти "новости" )) но если есть у них боковой виджет думаю можно и фото вывести 

 

Share this post


Link to post
Share on other sites

просьба выложите код шаблона  blog - front - widgets - entryRow   
у меня совсем перестал работать... 

Share this post


Link to post
Share on other sites
В 01.11.2016 в 15:01, Respected сказал:

AUS, привет, отправь в ЛС данные - посмотрю

Спасибо, Павел. Сейчас поддержка IPS внесла какие-то изменения, проблемные блоги восстановили и даже боковой виджет заработал. 
но вот код - не пашет , не выводит ни чего, вместо этого в боковом Блоке появляется сообщение error и всё . 

{{$content = new \DOMDocument;}}
{{$content->loadHTML( $entry->content() );}}
{{$src = $content->getElementsByTagName('img')->item(0)->getAttribute('src');}}
{{\IPS\Output::i()->parseFileObjectUrls( $src );}}
<a class="ipsAttachLink ipsAttachLink_image" href="{$src}" rel="external nofollow noopener noreferrer" target="_blank" style="display: block; max-width: 223px;" data-ipslightbox><img src="{$src}" class="ipsImage ipsImage_thumbnailed"></a>

написал им опять мол 4.1.14 и 4.1.15 работало а в 4.1.16 не работает - жду ответа от них. 
если что новости потом тут напишу. 

проблема в том что они не пишут что именно сделать - пишут "мы внесли изменения" и всё на этом 

Share this post


Link to post
Share on other sites

В общем на моём же сервер у меня есть второй форум (можно считать тестовым) всё работает. 
Получается, что проблема не в конфигурации окружения (nginx, php и т.д.) а где то в самом движке.

На своём форуме пробовал создавать новый Шаблон с нуля, но Блок не пашет и на чистом шаблоне. Значит проблема и не в шаблоне, а где-то глубже. 

Share this post


Link to post
Share on other sites

Что бы устранить проблему само-удаления блогов саппорт внес изменения в файл /forum/applications/blog/extensions/core/MemberSync/Blog.php

было:
 

	public function onDelete( $member )
	{
		\IPS\Db::i()->update( 'blog_rss_import', array( 'rss_member' => 0 ), array( 'rss_member=?', $member->member_id ) );

		foreach( \IPS\blog\Blog::loadByOwner( $member ) as $blog )
		{
			$blog->delete();
		}
	}

стало:

	public function onDelete( $member )
	{
		\IPS\Db::i()->update( 'blog_rss_import', array( 'rss_member' => 0 ), array( 'rss_member=?', $member->member_id ) );
		
		foreach( \IPS\blog\Blog::loadByOwner( $member ) as $blog )
		{
			/* We only want to do this if the blog is owned by the member - loadByOwner() also returns Blogs that are assigned to member groups */
			if ( !$blog->groupblog_ids )
			{
				$blog->delete();
			}
		}
	}

может кому пригодится... 

Share this post


Link to post
Share on other sites

Однако блок я пока так и не починил - при вставке кода вывода картинки начинаются проблемы. 
В логах nginx выводит нечто такое:

 

2016/11/07 22:58:15 [error] 819#0: *232328 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Call to a member function getAttribute() on null in /home/aus/www/asc.kz/forum/system/Theme/Theme.php(744) : eval()'d code on line 1077" while reading response header from upstream, client: 95.56.242.34, server: asc.kz, request: "GET /forum/ HTTP/1.1", upstream: "fastcgi://unix:/tmp/php5-fpm.sock:", host: "asc.kz", referrer: "https://asc.kz/forum/admin/?adsess=ai6c6e629doh4rduuqvng5fi57&"


2016/11/07 22:59:11 [error] 819#0: *232415 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Call to a member function getAttribute() on null in /home/aus/www/asc.kz/forum/system/Theme/Theme.php(744) : eval()'d code on line 1077" while reading response header from upstream, client: 95.56.242.34, server: asc.kz, request: "GET /forum/index.php?app=core&module=system&controller=widgets&do=getBlock&blockID=app_blog_entryFeed_zxxkm9a5d&pageApp=forums&pageModule=forums&pageController=index&pageArea=sidebar&orientation=vertical&csrfKey=dde455ab9749ad6f00f697a89bbb530a HTTP/1.1", upstream: "fastcgi://unix:/tmp/php5-fpm.sock:", host: "asc.kz", referrer: "https://asc.kz/forum/"

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...