Перейти к содержанию
ram108

Рекомендации по настройке сервера для IPS 4

Рекомендуемые сообщения

Дорогие друзья, все вы наверное заметили, что четверка потребляет на порядок больше ресурсов сервера, чем третья версия. Здесь я напишу некоторые рекомендации, которые помогут оптимизировать ваши настройки.

Рекомендуемые ресурсы для четверки. VPS/VDS с 1GB памятью как минимум. Лучше 2GB + 2 CPU core. Я использую последнее, но при грамотной настройке, форум не будет потреблять более 1GB памяти. 

Отказаться от Apache и установить nginx+php-fpm. Этим шагом вы сразу значительно увеличите скорость исполнения вашего форума и уменьшите количество потребляемых ресурсов, т.к. отказываетесь от ресурсоемкого сервера Apache. Вместо него используется быстрый сервер nginx.

Конфигурация php-fpm для 1GB памяти:

pm = dynamic
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 3
pm.max_children = 8
pm.process_idle_timeout = 10s
pm.max_requests = 300

Конфигурация php-fpm для 2GB памяти.

pm = dynamic
pm.start_servers = 2
pm.min_spare_servers = 2
pm.max_spare_servers = 6
pm.max_children = 10
pm.process_idle_timeout = 10s
pm.max_requests = 500

Приведенные выше настройки php-процессора приблизительные. В каждом конкретном случае необходимо их настраивать более тонко.

Изменено пользователем ram108

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Также будет не лишним установить модуль кеширования для php. Он работает автоматически и позволят снизить нагрузку на диск и базу данных.

Пример. Установка модуля Opcache для Ubuntu и php7:

apt install php-opcache

После установки перезагрузить конфигурацию php-fpm

service php7.0-fpm reload

Все. Все ваши проекты на php теперь кешируются автоматически.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Не рекомендую устанавливать методы кеширования, предложенные форумом, если вы не знаете, что это такое. Это может привести только к большему потреблению памяти.

Данные методы подойдут для больших (база данных от 1GB) и посещаемых форумов. Если у вас именно такой форум, то, наверное, вы уже сами знаете о чем я здесь пишу.

Снимок.PNG

Изменено пользователем ram108

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Значение php memory_limit следует установить в 128M. Меньшее значение приведет к проблемам, таким, как невозможность загрузить расширение форума или языка перевода. Большее значение может увеличить потребляемую память, что негативно скажется на всем сервере.

memory_limit=128M

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, ram108 сказал:

Значение php memory_limit следует установить в 128M. Меньшее значение приведет к проблемам, таким, как невозможность загрузить расширение форума или языка перевода.

+ к невозможности установки IPS

(ругается если меньше 128)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Все эти советы, особенно с конкретными цифрами не имеют никакой полезности, а даже принесут вред новичкам.

Цитата

 

Рекомендуемые ресурсы для четверки. VPS/VDS с 1GB памятью как минимум. Лучше 2GB + 2 CPU core. Я использую последнее, но при грамотной настройке, форум не будет потреблять более 1GB памяти. 

 

Все зависит от размеров форума и его посещаемости,  правильнее говоря нагрузки. У меня 8-ми ядерный ксеон с SSD и 64Gb RAM под четверкой еле ходит. Своп активно используется при этом. На 32ГБайт четверка у меня по вечерам вообще не работала бы практически. 

Так что все параметры нужно подбирать индивидуально постоянно анализируя логи, активно пользуясь mysql тюнерами, постоянно мониторить параметры переменных mysql и т.д. У меня на это почти месяц ушел, только недавно все отточил и заставил форум нормально работать.

Совет про кэширование тоже вредный. Тот же Redis не требует настройки и автоматически выделяет столько памяти для себя, сколько требуется и есть свободной. Если я отключаю на своем серваке кэширование, то он ложится через 5 минут, а sql-slowlog за это время вырастает до нескольких сот мегабайт.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
7 часов назад, tolik777 сказал:

не имеют никакой полезности

Как раз таки новичкам они будут полезны. У кого форум побольше, должны иметь представление, как самостоятельно настроить сервер.

7 часов назад, tolik777 сказал:

Так что все параметры нужно подбирать индивидуально постоянно анализируя логи

Об этом я писал в самом начале поста. Но этот совет явно не для новичков.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

По тонкостям настройки вопрос уже индивидуальный конечно.

У меня принципиально вопрос к типу Apache или Nginx для IPS 4, какой все таки лучше? Потому как изначально стояла IPB и Apache. Сейчас перевел на IPS, а Apache остался.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Чтобы подробнее разобраться в этом вопросе, существует google. А вкратце я уже выше писал: 1) nginx потребляет на порядок меньше памяти, 2) nginx быстрее обрабатывает запросы. Если RAM и CPU на вашем сервере ограничены, то избавившись от Apache вы сразу заметите разницу. Но для перехода на nginx нужно иметь немного терпения и разобраться, как он работает. Самое главное отличие от Apache, nginx не обрабатывает файлы .htaccess. Вся конфигурация хранится централизовано.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

nginx на порядок быстрее апача. Я уже лет 8-мь на nginx сижу. Раньше он как бэкэнд  работал только на статику, но сейчас полностью от апача отказался. 
А если еще PHP 7.0 поставите, то еще прирост будет двухкратный как минимум.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Хостер подключил мне nginx+php-fpm, но он только на PHP 5.4, мол ISPmanager не совместим с PHP 7.0.

Апач вроде можно 7.0. Что выбрать?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 часа назад, alexbavar сказал:

ISPmanager не совместим с PHP 7.0

ISPmanager поддерживает пакеты системы по умолчанию. В Ubuntu 16.04 например только php7, более низкие версии не поддерживаются системой. Все прекрасно работает и ISPmanager и php7-fpm и nginx.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 минут назад, ram108 сказал:

ISPmanager поддерживает пакеты системы по умолчанию. В Ubuntu 16.04 например только php7, более низкие версии не поддерживаются системой. Все прекрасно работает и ISPmanager и php7-fpm и nginx.

Значит уже второй хостер мне парит мозг.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, alexbavar сказал:

Значит уже второй хостер мне парит мозг.

На шаред хостинге серьезные ограничения на ресурсы. Они в принципе не могут ставить все по пожеланию клиента. Если например взять VPS/VDS, то там вы можете ставить все что угодно. Ubuntu 16.04 изначально поставляется с php7 в стандартных репозитариях. ISPmanager поддерживает Ubuntu 16.04

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
49 минут назад, ram108 сказал:

На шаред хостинге серьезные ограничения на ресурсы. Они в принципе не могут ставить все по пожеланию клиента. Если например взять VPS/VDS, то там вы можете ставить все что угодно. Ubuntu 16.04 изначально поставляется с php7 в стандартных репозитариях. ISPmanager поддерживает Ubuntu 16.04

Дело в том что это VPS, но в рамках настроенного сервера только CentOS 7, в котором как объяснил хостер  ISPmanager не поддерживает PHP 7.0.  И да, предложили Ubuntu 16 + ISPmanager 5, но мне нужно будет все устанавливать и настраивать самому.

А в этом я не разбираюсь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

И как вариант, какие будут сложности при переносе форума с сервера с CentOS 7 (nginx+php5.4) на Ubuntu 16 (nginx+php7.0) ?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, alexbavar сказал:

CentOS 7 (nginx+php5.4)

Не встанет, минимальные требования php5.5, рекомендуется php7

1 час назад, alexbavar сказал:

Ubuntu 16 (nginx+php7.0)

Отличный выбор. Никаких трудностей быть не должно.

1 час назад, alexbavar сказал:

А в этом я не разбираюсь

Пишите в личку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 20.10.2016 в 05:26, ram108 сказал:

Дорогие друзья, все вы наверное заметили, что четверка потребляет на порядок больше ресурсов сервера, чем третья версия. Здесь я напишу некоторые рекомендации, которые помогут оптимизировать ваши настройки.

Рекомендуемые ресурсы для четверки. VPS/VDS с 1GB памятью как минимум. Лучше 2GB + 2 CPU core. Я использую последнее, но при грамотной настройке, форум не будет потреблять более 1GB памяти. 

Отказаться от Apache и установить nginx+php-fpm. Этим шагом вы сразу значительно увеличите скорость исполнения вашего форума и уменьшите количество потребляемых ресурсов, т.к. отказываетесь от ресурсоемкого сервера Apache. Вместо него используется быстрый сервер nginx.

Конфигурация php-fpm для 1GB памяти:

pm = dynamic
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 3
pm.max_children = 8
pm.process_idle_timeout = 10s
pm.max_requests = 300

Конфигурация php-fpm для 2GB памяти.

pm = dynamic
pm.start_servers = 2
pm.min_spare_servers = 2
pm.max_spare_servers = 6
pm.max_children = 10
pm.process_idle_timeout = 10s
pm.max_requests = 500

Приведенные выше настройки php-процессора приблизительные. В каждом конкретном случае необходимо их настраивать более тонко.

А куда эти команды прописывать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
2 часа назад, alexbavar сказал:

А куда эти команды прописывать?

В конфигурационный файл php-fpm. Обычно он находится в папке /etc/php5/fpm/pool.d/ 

Если нет хотя бы малейшего опыта в настройке VPS, то лучше ничего не трогать. Но на самом деле все очень просто, в интернете множество подробных инструкций на русском языке по настройке серверов.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
5 минут назад, ram108 сказал:

Если нет хотя бы малейшего опыта в настройке VPS, то лучше ничего не трогать.

имхо, эту фразу надо большими жирными буквами в первый пост

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Ребят, какую версию пыха лучше поставить, чтобы 4ка и 3.4  работали? 

А то знаю, в новых пыхах какие то функции удалены

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

IPS4 работает с php5.5 и выше. Рекомендуется php5.6 или php7. Последнее лучший вариант.

IPB3 работает с php5. На php7 тоже должна работать, но под нее не разрабатывалась и могут быть проблемы как с системой, так и с плагинами.

5 минут назад, HooLIGUN сказал:

в новых пыхах какие то функции удалены

Да, но на эти функции есть фиксы для IPB3. Проблемы начнутся с php5.6

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А я вот завидую белой завистью ipbmafia. Сайт грузится вообще без задержек. Не скажу что мой жутко тормозит, но разница в скорости навигации разительная. Очень хотелось бы увидеть от администрации советы по настройке сервера, примеры конфигов... И дизайн стиля хорош. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×