Перейти к содержанию
Авторизация  
Iluha321

Проблема с установкой IPB

Рекомендуемые сообщения

Добрый день, пытаюсь установить IPB nulled к себе на сервер.
Конфигурация сервера: nginx + php 7.1
Версию IPB ставлю:  4.1.5.1

При установке выдаёт следующую ошибку:
 

NO_STEP

 


 

Array
(
    [0] => Array
        (
            [function] => IPS\core\modules\setup\install\{closure}
            [class] => IPS\core\modules\setup\install\_install
            [type] => ->
            [args] => Array
                (
                    [0] => 
                )

        )

    [1] => Array
        (
            [file] => /home/forum.raknet.ru/system/Helpers/MultipleRedirect/MultipleRedirect.php
            [line] => 71
            [function] => call_user_func
            [args] => Array
                (
                    [0] => Closure Object
                        (
                            [this] => IPS\core\modules\setup\install\install Object
                                (
                                    [url] => IPS\Http\Url Object
                                        (
                                            [url:protected] => https://forum.raknet.ru/admin/install/index.php?app=core&module=install&controller=install
                                            [data] => Array
                                                (
                                                    [scheme] => https
                                                    [host] => forum.raknet.ru
                                                    [path] => /admin/install/index.php
                                                    [query] => app=core&module=install&controller=install
                                                )

                                            [queryString] => Array
                                                (
                                                    [app] => core
                                                    [module] => install
                                                    [controller] => install
                                                )

                                            [isInternal] => 1
                                            [isFriendly] => 
                                        )

                                )

                            [parameter] => Array
                                (
                                    [$data] => <required>
                                )

                        )

                    [1] => 
                )

        )

    [2] => Array
        (
            [file] => /home/forum.raknet.ru/applications/core/modules/setup/install/install.php
            [line] => 97
            [function] => __construct
            [class] => IPS\Helpers\_MultipleRedirect
            [type] => ->
            [args] => Array
                (
                    [0] => IPS\Http\Url Object
                        (
                            [url:protected] => https://forum.raknet.ru/admin/install/index.php?controller=install
                            [data] => Array
                                (
                                    [scheme] => https
                                    [host] => forum.raknet.ru
                                    [path] => /admin/install/index.php
                                    [query] => controller=install
                                )

                            [queryString] => Array
                                (
                                    [controller] => install
                                )

                            [isInternal] => 1
                            [isFriendly] => 
                        )

                    [1] => Closure Object
                        (
                            [this] => IPS\core\modules\setup\install\install Object
                                (
                                    [url] => IPS\Http\Url Object
                                        (
                                            [url:protected] => https://forum.raknet.ru/admin/install/index.php?app=core&module=install&controller=install
                                            [data] => Array
                                                (
                                                    [scheme] => https
                                                    [host] => forum.raknet.ru
                                                    [path] => /admin/install/index.php
                                                    [query] => app=core&module=install&controller=install
                                                )

                                            [queryString] => Array
                                                (
                                                    [app] => core
                                                    [module] => install
                                                    [controller] => install
                                                )

                                            [isInternal] => 1
                                            [isFriendly] => 
                                        )

                                )

                            [parameter] => Array
                                (
                                    [$data] => <required>
                                )

                        )

                    [2] => Closure Object
                        (
                            [this] => IPS\core\modules\setup\install\install Object
                                (
                                    [url] => IPS\Http\Url Object
                                        (
                                            [url:protected] => https://forum.raknet.ru/admin/install/index.php?app=core&module=install&controller=install
                                            [data] => Array
                                                (
                                                    [scheme] => https
                                                    [host] => forum.raknet.ru
                                                    [path] => /admin/install/index.php
                                                    [query] => app=core&module=install&controller=install
                                                )

                                            [queryString] => Array
                                                (
                                                    [app] => core
                                                    [module] => install
                                                    [controller] => install
                                                )

                                            [isInternal] => 1
                                            [isFriendly] => 
                                        )

                                )

                        )

                )

        )

    [3] => Array
        (
            [file] => /home/forum.raknet.ru/system/Dispatcher/Controller.php
            [line] => 94
            [function] => manage
            [class] => IPS\core\modules\setup\install\_install
            [type] => ->
            [args] => Array
                (
                )

        )

    [4] => Array
        (
            [file] => /home/forum.raknet.ru/system/Dispatcher/Setup.php
            [line] => 222
            [function] => execute
            [class] => IPS\Dispatcher\_Controller
            [type] => ->
            [args] => Array
                (
                )

        )

    [5] => Array
        (
            [file] => /home/forum.raknet.ru/admin/install/index.php
            [line] => 13
            [function] => run
            [class] => IPS\Dispatcher\_Setup
            [type] => ->
            [args] => Array
                (
                )

        )

)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Кое как установил, ошибки при URL www.forum.x.ru/admin:
Error: [] operator not supported for strings (0)
#0 /home/forum.x.ru/system/Output/Javascript/Javascript.php(776): IPS\Output\_Javascript::_writeJavascriptFromResultset(Array, 'library.js', 'global', 'root')
#1 /home/forum.x.ru/system/Output/Output.php(475): IPS\Output\_Javascript::compile('global', 'root', 'library.js')
#2 /home/forum.x.ru/system/Output/Output.php(245): IPS\_Output::_getJavascriptFileObject('global', 'root', 'library.js')
#3 /home/forum.x.ru/system/Dispatcher/Standard.php(74): IPS\_Output->js('library.js')
#4 /home/forum.x.ru/system/Dispatcher/Admin.php(91): IPS\Dispatcher\_Standard::baseJs()
#5 /home/forum.x.ru/system/Dispatcher/Dispatcher.php(86): IPS\Dispatcher\_Admin->init()
#6 /home/forum.x.ru/admin/index.php(13): IPS\_Dispatcher::i()
#7 {main}

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 час назад, Iluha321 сказал:

Версию IPB ставлю:  4.1.5.1

Лол. Меньше пейте на НГ

Актуальная версия - 4.1.17.1

СЕМНАДЦАТЬ, а не ПЯТЬ, Карл

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

В начале я ставил актуальную версию, т.е.  4.1.17.1 , потом подумал, что нужно протестировать и поставить более раннюю, но это никак не помогло. Везде одна и таже ошибка

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 минуты назад, Iluha321 сказал:

В начале я ставил актуальную версию, т.е.  4.1.17.1 , потом подумал, что нужно протестировать и поставить более раннюю, но это никак не помогло. Везде одна и таже ошибка

А всё почему, потому, что даже в 17 версии поддержки PHP 7.1 нет

Ставьте PHP 7.0 и IPS 4.1.17.1 и будет всё хорошо

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.
Авторизация  

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×