Перейти к содержанию
Авторизация  
shaxoff

Ошибка обновления

Рекомендуемые сообщения

Всем привет. Нужна помощь опытных. Обновить решил я доску с 3.5.7 вроде на 4.1.7. Всё скопировал, запустит апдейтер, он обновил, но сайт так и не запустился.  Крутится такое вот окно как в аттаче и всё. Ни в админку, никуда войти не могу.

2017-01-09_12-19-55.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да, сейчас разворачиваю бэкап. И sql, и файловый архив сделал.

Я так понимаю, базу тоже надо восстанавливать, если разворачиваю бэкап от 3.5.7?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

UPD. После разворачивания архива

 

Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /home/host1363972/clubarmada.ru/htdocs/www/initdata.php:382 Stack trace: #0 /home/host1363972/clubarmada.ru/htdocs/www/index.php(21): require_once() #1 {main} thrown in /home/host1363972/clubarmada.ru/htdocs/www/initdata.php on line 382

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

меняйте версию php на хостинге , она должна быть выше. 5.5.

либо 5.6. либо 7.0

если не поможет, значит ресурсов у вашего хоста мало, 4.х.х очень "обжорливая"

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Сейчас поставлю 7.0, и ещё раз обновлю.

Блин, хрен там.

2017-01-09_14-05-49.png

Вопрос: сейчас разверну с нуля, импортировать если данные тупо со старой базы не прокатит?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
6 часов назад, shaxoff сказал:

Обновить решил я доску с 3.5.7 вроде на 4.1.7.

Ставить лучше последнюю версию 4.1.17.1

4 часа назад, shaxoff сказал:

7.1 стоит

Не поддерживается 

44 минуты назад, shaxoff сказал:

Сменил PHP с 7.0 на 5.6 и вуаля.

5.6 не поддерживается. Визуально будет работать, но по логам ошибок вы поймете, что это не так.

Требуется версия php7.0

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

ram108, да держит 5,6. 2 заказчика на нём и всё ок. Но лучше да 7, раз рекомендуют разрабы. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

5.6 не поддерживает некоторые конструкции ООП, которые применены в IPS, варнинги и ошибки можно увидеть в логах. Это приведет к неожиданным ошибкам, репорты о которых уже были на мафии и решались переездом на php7.0

Буквально два дня назад помогал переносить и апгрейдить форум, на 5.6 не завелся.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Иногда это от расположения планет зависит... ;)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация  

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×