Перейти к содержанию
SlawkA

Easy mention 1.0.0

Рекомендуемые сообщения

Easy mention 1.0.0


Плагин ответ по нику @ на форуме , для версии 4.2

Этот плагин добавляет новую кнопку для каждого сообщения, которое позволяет вам легко указывать пользователей, помещая их имена в текстовую область ответа.

Поддерживает темы и комментарии форума (например. Blogs, Gallery).

This plugin adds a new button to every post which allows you easily mention users by putting their names into the reply text area.

Supports forum topics and comments (e.g. Blogs, Gallery).


 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
9 минут назад, ODLine сказал:

На релизе 4.2.4 не работает.

перезагружает страницу и всё...

все прекрасно работает на 4.2.4

 

Спойлер

111111.thumb.png.94c15ffdadc3f93e1f55d469f4039616.png

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
14 минут назад, ODLine сказал:

На релизе 4.2.4 не работает.

перезагружает страницу и всё...

Возможно это из за стиля! Пробуйте на дефолтном.

59cac0b499b6e_27_2017.0_01_34.gif.e8c316c6c8f1ae770a84ad35bbee192b.gif

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, Sipsb сказал:

Возможно это из за стиля! Пробуйте на дефолтном.

я пробовал на этом стиле.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 27.09.2017 в 00:06, SlawkA сказал:

я пробовал на этом стиле.

 

Стиль другой, но фигня такая же.

Вместо кнопки вставляет просто "@Ник" - обычным шрифтом. Причем, если посмотреть в момент рефреша страницы, видно, что кнопка вначале появляется, а потом пропадает и остается только Ник.

Все перерыл уже - не могу понять, в чем проблема.

P.S. На дефолтном все работает

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
4 минуты назад, VladOr сказал:

P.S. На дефолтном все работает

ну вот так и должно работать. это стиль титан для 4.2

Спойлер

3.thumb.JPG.821f415f12710ca80a4d20c4a597bd2f.JPG

ну попробуй это заменить на своём стиле.

этот код сюда.

Спойлер

1.thumb.JPG.1362c37bf8983b48a3ad4d82eeb4dc55.JPG

{{if settings.insname_location == 'post'}}
	<li style="margin-right:5px;">
		<a href="#" data-name="{$author->name}" {{if $author->member_id AND settings.insname_insert_as != 'text'}}data-member-id="{$author->member_id}" data-profile="{$author->url()}" data-hovercard="{$author->url()->setQueryString('do', 'hovercard')}"{{endif}}{{if settings.insname_add_at}} data-at="1"{{endif}} class="insertName ipsButton ipsButton_light ipsButton_verySmall ipsButton_narrow cMultiQuote" style=""><i class="fa fa-bullhorn"></i></a>
	</li>
{{else}}
	<a href="#" data-name="{$author->name}" {{if $author->member_id AND settings.insname_insert_as != 'text'}}data-member-id="{$author->member_id}" data-profile="{$author->url()}" data-hovercard="{$author->url()->setQueryString('do', 'hovercard')}"{{endif}}{{if settings.insname_add_at}} data-at="1"{{endif}} class="insertName"><i class="fa fa-bullhorn"></i></a>
{{endif}}

это сюда в CSS

Спойлер

2.thumb.JPG.4fab21abefcf0055f910f9bedf554299.JPG

h3 .insertName{
	position: relative;
	font-size: 23px;
    color: #05768f;
}
li .insertName{
	font-size: 17px !important;
}

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

CSS у меня такого вообще не было. Вставил код в custom - не заработало.

Ок, создал CSS - результат тот же :(

Т.е. при рефреше на долю секунды появляется синяя кнопка с @Ник а потом, как будто толи слетает, толи ее что то сверху перекрывает - статовится обычным некликабельным текстом.

И по F12 - в коде отсутствует строка с созданием блока.

Код в дефолтном скине:

<div data-role="commentContent" class="ipsType_normal ipsType_richText ipsContained" data-controller="core.front.core.lightboxedImages">
<p>
	<a contenteditable="false" data-ipshover="" data-ipshover-target="https://mypetclub.ru/profile/1-vlador/?do=hovercard" data-mentionid="1" href="https://mypetclub.ru/profile/1-vlador/" rel="">@VladOr</a>&nbsp;тест&nbsp;
</p>

</div>

Код в скине, где кнопка не отрабатывает:

<div data-role="commentContent" class="ipsType_normal ipsType_richText ipsContained" data-controller="core.front.core.lightboxedImages">
			<p>
	@VladOr&nbsp;тест&nbsp;
</p>

			
</div>

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
11 минут назад, VladOr сказал:

Ок, создал CSS - результат тот же :(

сам код CSS попробуй в CUSTOM закинуть нужного стиля.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Только что, SlawkA сказал:

сам код CSS попробуй в CUSTOM закинуть нужного стиля.

Ну я в первую очередь это сделал. Потом уже, когда результата не принесло - создал CSS

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Только что, VladOr сказал:

Ну я в первую очередь это сделал.

а сам сторонний стиль для 4.2 версии форума? или с 4.1 остался?

просто если с 4.1 остался. то возможно не подходит он к плагину.

поставь любой другой стиль НО только для 4.2, и проверь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Да, проверил. На другом стиле для 4.2 отрабатывает нормально.

Но мой стиль уже перепаханный под себя. Менять нельзя.

Теперь ковырять, где проблема

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, VladOr сказал:

Но мой стиль уже перепаханный под себя. Менять нельзя.

Теперь ковырять, где проблема

у меня их было 4 на 4.1

при обнове до 4.2 пришлось положить на них болт.

и начинать все заново. ну потратил на это часа 2, какие то стили типа титан просто обновил и запилил обратно под себя.

а какие то стили просто новые поставил и так же под себя их.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
1 минуту назад, SlawkA сказал:

и начинать все заново. ну потратил на это часа 2

Ну я уже половину не помню, что делал. Там не два часа будет. Да и жаль, все остальное, что поначалу в 4.2 не работало - поправил. Одна вот эта фишка щас осталась.

Причем, плагин EasyMention не причем. Не работает просто стандартная функция Mention, т.е. если в форме ответа ввести @ и набирать ник пользователя - он его дает и в форме ответа вставляет нормально - на кнопке синего цвета.

А вот после отправки уже сообщения - получается такой косяк.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Проблема решена.

Если кому интересно:

В своем скине нужно полностью заменить содержимое шаблона includeJS содержимым этого же шаблона из скина, предназначенного для новой версии IPS. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 21.11.2017 в 14:27, VladOr сказал:

Проблема решена.

Если кому интересно:

В своем скине нужно полностью заменить содержимое шаблона includeJS содержимым этого же шаблона из скина, предназначенного для новой версии IPS. 

Где искать этот файл в шаблонах?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
26 минут назад, Darksoul сказал:

Где искать этот файл в шаблонах?

в поиск в нужном стиле введи includeJS

1.thumb.JPG.61cb001a6018e0c85edca3b27863f827.JPG

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
В 21.11.2017 в 14:27, VladOr сказал:

У

3 минуты назад, SlawkA сказал:

в поиск в нужном стиле введи includeJS

1.thumb.JPG.61cb001a6018e0c85edca3b27863f827.JPG

вот что выдало:
5a1d343cb97f1_-1.thumb.png.e6ec94fcad8275144a074d263a636ad8.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
34 минуты назад, Darksoul сказал:

Darksoul отреагировал на это

не надо мне лайки ставить. а то опять верещать начнут жалобу Админу что я себе их набиваю.

2 минуты назад, Darksoul сказал:

вот что выдало:

ну так другие разделы то открой. посмотри у меня на скрине какие нужно разделы открыть

Изменено пользователем SlawkA

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А как создать файл insertname, а то у меня его вообще нет почему-то, и кнопка вообще не отображается соответственно.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Только что, Darksoul сказал:

А как создать файл insertname, а то у меня его вообще нет почему-то, и кнопка вообще не отображается соответственно.

а сам плагин стоит хоть?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Создал файл insertName.phtml с кодировкой utf-8, по пути где он должен лежать, вставил в него нужное содержимое, почистил кэш, но движок не видит этот файл, права на нём 777, странно как-то.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
3 минуты назад, Darksoul сказал:

Не работает, помогите кто нибудь плиз)

блин ну как он не работает у тебя? если у меня он работает ДАЖЕ в ПОЧТЕ.

зайди на мой сайт и сам попробуй

Логин: TEST

Пароль: 123456TEST

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×