Jump to content

Перенос форума на другой хостинг


Recommended Posts

Если бы ты с сервера на сервер хотел переехать...

Как вариант получить доступ по SSH и выполнить команду

mysqldump -uпользовательБД -pпарольБД --add-drop-table ИМЯ_БД > /home/hosting/user/site/DB.sql

файлы сайта выкачать по FTP вместе с тем что получился командой выше.

На новом сайте

по SSH команда

mysql -uпользовательБД -pпарольБД ИМЯ_БД < DB.sql
С файлами думаю проблем не будет.

 

Link to post
Share on other sites
1 час назад, aplayer сказал:

файлы сайта выкачать по FTP вместе с тем что получился командой выше.

Это плохой совет. FTP во-первых медленно качает из-за инициализации старта каждого файла, во-вторых бывает не все файлы выкачивает (потому что на хостингах бывает часто лимит в 5-10т файлов для FTP в одной папке).

Правильнее, раз уж есть SSH - то делать там архив файлов: tar -cjf backup.tar.bz2 --directory=/…/…/ domain

 

А базу лучше жать в архив сразу командой типа mysqldump … | bzip2 > backup.sql.bz2

Оно раз в 10 ужимается, гораздо быстрее сливается и гарантия защиты от повреждения (в виде контрольной суммы архива).

Link to post
Share on other sites
3 минуты назад, Respected сказал:

Скорее всего версия php не подходящая.

а какая должна?

Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE) in /home/buan/wolhwinfo.ru/docs/init.php on line 1201 вот такая полная ошибка

Link to post
Share on other sites

Вроде все встало.Антиспам только выдает ошибку.Как исправить?

ParseError: syntax error, unexpected ';', expecting ')' (0)
#0 [internal function]: IPS\IPS::autoloader('IPS\\core\\module...')
#1 [internal function]: spl_autoload_call('IPS\\core\\module...')
#2 /home/buan/wolhwinfo.ru/docs/system/Dispatcher/Dispatcher.php(141): class_exists('IPS\\core\\module...')
#3 /home/buan/wolhwinfo.ru/docs/admin/index.php(14): IPS\_Dispatcher->run()
#4 {main}

Link to post
Share on other sites
  • 6 months later...

Нужна помощь! Версия 4.4.10 нуллед. Копирую форум.ру на текстовый поддомен тест.форум.ру. Скопирвал файлы, скопировал базу, поправил данные по подключению к базе в файле conf_global.php. Форум грузится криво, без загрузки стилей css (предположение). В админке ошибка  Что-то пошло не так. Пожалуйста, попробуйте еще раз.

Прошу помочь, что я упустил?

Edited by Catalo
Link to post
Share on other sites
1 час назад, Catalo сказал:

Прошу помочь, что я упустил?

ну в первую очередь нужно очистить кэш.

перепроверить пути. если на поддомене

Edited by SlawkA
Link to post
Share on other sites
9 минут назад, SlawkA сказал:

ну в первую очередь нужно очистить кэш.

перепроверить пути. если на поддомене

Админка не работает, не могу очистить кэш. Перепроверить пути - где? Находил тут тему на что надо базу текстовым редактором открыть и там пути смотреть, но там речь была про IPB 3.X. 

Link to post
Share on other sites
43 минуты назад, Catalo сказал:

Находил тут тему на что надо базу текстовым редактором открыть и там пути смотреть, но там речь была про IPB 3.X. 

Попробовал даже это проделать - не помогло.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...