Jump to content

Небольшие проблемы после обновления 3.4->4.3


Kinkl
 Share

Recommended Posts

Всем привет!

Спустя почти два года решил все-таки обновиться уже на 4-ую ветку, раньше по каким-либо причинам не удавалось никак. Лучше поздно, чем никогда, как говорится :)
В общем, на локалке развернул сайт, закинул файлы IPS4, запустил процесс обновления. Все прошло нормально, без ошибок. Вопросы появились позже, а конкретно:

1. Во многих местах сайта, включая приложение Downloads не отформатировался код, причем как-то странно, в некоторых местах полностью, в других наполовину. Конкретнее, описания файлов выглядят примерно так:

<ul>
			<li>
				Test string
			</li>
			<li>
				Test string
			</li>
			<li>
				Test string
			</li>
		</ul>

		<p>
			[*]Test string
		</p>

		<p>
			[*]Test string
		</p>

		<p>
			[*]Test string
		</p>
	</li>
</ul>

Вручную все это править не вариант, файлов в архиве более 7000. Хочется понять из-за чего это возникает.

2. Еще одна проблема, это аттачменты на форуме. Они выводятся не в исходном виде, а вот так:

[attachment=1335:myattachment.png]

Это из основного, что хотелось бы исправить в первую очередь перед обновлением, остальное вроде не очень значительно. Добавлю что база размером около 500мб, при обновлении не возникло ни одной ошибки, следил за процессом.

Буду рад любой помощи, спасибо! :)

Link to comment
Share on other sites

После обновления в адмике запускаются фоновые процессы, после того, как они завершатся, данных проблем быть не должно.

Link to comment
Share on other sites

Respected а можно как-то посмотреть, выполнились ли они корректно? Или даже запустить их заново. В новой админке вообще не могу нормально ориентироваться пока, непривычно совсем.

Link to comment
Share on other sites

Respected ага, увидел, висело три процесса, но там в основном про комментарии к файлам было. Запустил вручную, выполнились до конца. Проверил аттачменты, с ними все стало нормально, отображаются. А с описаниями все равно что-то не то. Как я понял, код по идее отформатировался нормально, но пока я вижу что осталась проблема с вложенным списком, который я привел в пример в первом сообщении. Вот, чтобы было нагляднее:

1.jpg.4f053abd0952bbb6d5fe9c4eb63d280c.jpg

А вот код, видно где пошло неправильное преобразование:

<p><strong>Description of file here</strong></p>

<p><span class="ipsBadge ipsBadge_green">ABOUT</span></p>
<ul>
<li>Test string
</li>
<li>Test string<ul>
<li>
<strong>Test string</strong>
</li>
<li>
<strong>Test string</strong>
</li>
<li>
<strong>Test string</strong>
</li>
</ul>
<p></p>
<p>[*]Test string</p>
<p>[*]Test string</p>
<p>[*]Test string</p>
<p></p>
</li>
</ul>

<p><span class="ipsBadge ipsBadge_green">SOFTWARE</span></p>
<ul><li>
<a href="http://test.ru" target="_blank"><strong>Test link</strong></a> – link<br>
</li></ul>

<p><span class="ipsBadge ipsBadge_red">WARNING!</span></p>
<ul>
<li>
<strong>Test string</strong>
</li>
<li>Test string
</li>
<li>Test string
</li>
<li>
<span style="color:rgb(255,0,0)"><strong>Test string</strong></span><br>
</li>
</ul>

 

2.jpg

Последний скрин прилепил, есть небольшой вопрос, в принципе уже понял почему эти места не отображаются, разрабы видимо ампутировали тэг <span class="ipsBadge ipsBadge_цвет">. А есть ли его замена в новой IPS, или придется добавлять старый в стили?

Link to comment
Share on other sites

Respected спасибо, с этим разобрался. Запросом к базе поменял теги, пусть лучше новые будут :)

Вопрос с поехавшим list так и не решил, видимо придется руками править где есть...

Появилось еще несколько вопросов в процессе настройки:

1. Не работает функция Embed на стандартных объектах IPS: темы, файлы, галерея и т.д. Вставляются просто ссылки. При этом встраивание видео например с YouTube работает нормально. И еще заметил, в сообщениях, где ссылались на файлы во время IPB 3.4 (через функцию Media) ссылки выглядят так: http://mysite.com/files/file/7239-%7B%3F%7D/ То что выделено жирным - во всех ссылках с файлами одинаково. 

2. После установки руссификации разделители целой части у больших чисел стали такими: То есть количество пользователей, файлов и прочее отображается с этим ромбом-вопросом. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...