Перейти к содержанию

malinin1991

Пользователи
  • Публикаций

    31
  • Зарегистрирован

  • Посещение

Информация о malinin1991

  • Звание
    Пользователь
  • День рождения 12.10.1991

Информация

  • Форум
  • Пол
    Мужчина
  • Город
    Новосибирск
  • Версия IP.Board
    4.2

Контакты

  • Skype
    malinin1991

Посетители профиля

1 170 просмотров профиля
  1. Разобрался. Дело было во включенном хранении сессий в memcached. После отключения запросы стали ходить нормально.
  2. Из всех методов REST API работает только /api/core/hello { "communityName": "ДИКИЕ КОТЫ, отдельная танковая бригада", "communityUrl": "https://wcat1.ru/", "ipsVersion": "4.2.5" } При попытке использовать что-либо кроме этого метода возвращается 500 ошибка. Если использовать метод POST-типа, то данные отправляются, обрабатываются, но в ответ всё равно приходит 500 ошибка. Из логов в дебаг режиме смог вытянуть только, что rewrite работает корректно: В логах PHP ошибок не нашёл, в логах форума тоже Кусок конфига nginx для /api location /api/ { if (!-e $request_filename){ rewrite ^/api/(.*)$ /api/index.php; } } PHP: 7.1.9 nginx: 1.13.5 IPS: 4.2.5 В чём может быть проблема? Возможно, что ещё какие-то конфиги нужны. Хочется всё же решить эту проблему
  3. При редактировании группы, если включен модуль "Загрузки", в админке вываливается ошибка: Если модуль отключить, всё ОК. Конфигурация сервера: PHP 7.1.9 + nginx 1.13.5 Версия форума: 4.2.4 (ошибка наблюдается как минимум с 4.2.2) На форуме находил тему с подобной проблемой, но там это наблюдалось в бете и был совет ждать релиза. Обновление движка проводилось минуя бета-версии, с 4.1.19 на 4.2. Не то, чтобы ошибка была критичной, но хотелось бы разобраться и не отключать модуль загрузок каждый раз, когда нужно поправить группу.
  4. https://invisioncommunity.com/files/file/7853-online-indicator/ https://invisioncommunity.com/files/file/7449-auto-welcome/ https://invisioncommunity.com/files/file/7310-group-legend/ Если можно
  5. Угу, и правда много было, причём как остатки от IPB3, так и punBB. Ну и там в корне немного моих папок лежит) Надо по-хорошему перебрать... + поиграться с чистой базой (структуру посмотреть) наверняка тоже много мусора найду
  6. Значит наиболее вероятное, что при апдейте не было учтено разработчиками... Тот форум когда-то работал на 3-ке, а до этого вообще на чём-то типа punBB, потом перевёл его на 4 версию, при этом все директории сохранились.
  7. Судя по строкам </ipb-protection> похоже на стандартный, хотя возможно, что какой-то из модов дописал своё, как минимум руками я этот файл там не правил)
  8. Нашёл в /uploads/.htaccess было такое: #<ipb-protection> <Files ~ "^.*\.(php|cgi|pl|php3|php4|php5|php6|phtml|shtml)"> Order allow,deny Deny from all </Files> <ifModule mod_headers.c> Header set Content-Disposition attachment </ifModule> #</ipb-protection> Закомментировал строчку с Content-Disposition и фотки стали открываться в браузере. Собственно, не сломает ли это что-то на форуме? Проверил для текстовых файлов и разнового рода архивов/XML, файлы корректно загружаются с сервера.
  9. Попробовал, перезапустил апач. Всё равно предлагает скачать файл (пробовал в режиме инкогнито и другом браузере). В директории uploads тоже есть .htaccess, но он там стандартный.
  10. При переходе по прямой ссылке на картинку открывается окно загрузки файла, а не сама картинка в браузере. Тоже самое происходит, если нажать ссылку "Полный размер" в просмотрщике картинок Подскажите, пожалуйста, в чём может быть проблема. Пример картинки: https://wcat1.ru/uploads/monthly_2017_07/image.jpg.9b7c47eb7995ca96b8ac97bb97243155.jpg Подозреваю, что дело в Apache и файлах .htaccess, но не могу понять, что именно не так.
  11. https://invisionpower.com/files/file/3070-member-map/ если можно
  12. С модом ничего не вышло, как я понимаю?
  13. https://invisionpower.com/files/file/3070-member-map/
×