Jump to content

IPS не видит базу от IPB


Nixon13
 Share

Recommended Posts

Здравствуйте.

Такая проблема: вычитал на тут форуме как переходить с ipb на ips.Сконвертировал базу,установил IPS,но форум базу так и не видит.Рылся в админке,думал как в ipb может есть пересчёт или обновление кэша,в общем ничего подходящего не нашёл.

Link to comment
Share on other sites

Только что, Respected сказал:

Что значит не видит?

Для пользователей например создал себе базу _defaultcore_members  хотя members от ipb тоже сконвертировал.

Пробовал переименовать - выдаёт ошибку. 

Link to comment
Share on other sites

Информации вообще нет, желательно описывать свои действия последовательно, иначе ответа можно ждать до весны

Link to comment
Share on other sites

Знать бы что именно описывать)

Был форум IPB в вирусах,сконвертировал его через uft8converter ,потом удалил всё и поставил ips 4.0 nulled,но форум показывал уже новую базу ,потом обновил его до 4.1.4.1,ничего не изменилось разумеется.Попытался переименовать старую таблицу пользователей под новую, когда нашёл какая именно сейчас используется...но ничего не вышло,форм видимо не может её считать и выдаёт ошибку.

*сконвертировал базу того форума имею ввиду.

Теперь уже вопрос наверно в том как указать форуму верные базы,да так чтоб они работали...

Точнее таблицы а не базы,он всё пихнул в одну базу.

Link to comment
Share on other sites

В корне неправильное решение. Нужно восстановить форум, к которому подходит база, потом обновлять до 4.1

Link to comment
Share on other sites

8 минут назад, Respected сказал:

В корне неправильное решение. Нужно восстановить форум, к которому подходит база, потом обновлять до 4.1

после конвертации форум(ipb) вместо текста выдавал знаки вопроса

Это нормально?

Link to comment
Share on other sites

Здесь нужно смотреть на кодировку в базе, соединения, конфига форума. Решение всегда можно найти, а вот все удалять и прикручивать старую базу к новому форуму не стоит.

Link to comment
Share on other sites

1 час назад, Respected сказал:

Здесь нужно смотреть на кодировку в базе, соединения, конфига форума. Решение всегда можно найти, а вот все удалять и прикручивать старую базу к новому форуму не стоит.

Удалять пришлось бы так и так,на форуме сидели вирусы,в каких-то из модулей или хуков,а их там был вагон,антивирусы не видели.

Спасибо за ответ,буду пробовать поставить ipb и обновить.

Link to comment
Share on other sites

Никогда не нужно делать поспешных выводов. После обновления на 4.1 все бы вирусы сами удалились - 99%. Опять же, можно проверить форум антивирусом и удалить его из файлов.

Link to comment
Share on other sites

11 часов назад, Nixon13 сказал:

Знать бы что именно описывать)

Был форум IPB в вирусах,сконвертировал его через uft8converter ,потом удалил всё и поставил ips 4.0 nulled,но форум показывал уже новую базу ,потом обновил его до 4.1.4.1,ничего не изменилось разумеется.Попытался переименовать старую таблицу пользователей под новую, когда нашёл какая именно сейчас используется...но ничего не вышло,форм видимо не может её считать и выдаёт ошибку.

*сконвертировал базу того форума имею ввиду.

Теперь уже вопрос наверно в том как указать форуму верные базы,да так чтоб они работали...

Точнее таблицы а не базы,он всё пихнул в одну базу.

А зачем вы удалили всё?

Нужно было сохранить файл conf_global, папку public и uploads как минимум.

Потому движок и не увидел старую БД.

Link to comment
Share on other sites

5 часов назад, IAF сказал:

А зачем вы удалили всё?

Нужно было сохранить файл conf_global, папку public и uploads как минимум.

Потому движок и не увидел старую БД.

Я всё предварительно скачал,а удалил т.к. проверял кучей разных антивирусов,чистил форум,но через день-два вирус возвращался.

Link to comment
Share on other sites

Вроде базу прилепил,но теперь с кодировкой что-то,хоть и конвертировал.Вместо текстов знаки вопроса.

Link to comment
Share on other sites

2 минуты назад, Nixon13 сказал:

Аватары пользователей тоже почему-то пропали после конверта базы

А права выставили? 

Link to comment
Share on other sites

Пропала сама папка,путь изображений ведёт к uploads/profile/картинка.png  ,а папки prifile в uploads нет.

Может конечно на ipb она была не там и ссылки изменились,но вот как-то так выходит...

Link to comment
Share on other sites

Вопрос решён.

 

С IPB 3.4.8 надо обновляться сперва на IPS 4.0.13.1 nulled от IAF,ничего не конвертируя,она всё сконвертирует сама если нужно.

А затем уже и дальше до 4.1.4.1 без проблем с кодировкой и потерь.

 

 

Только один вопрос остался,стоит ли нажимать Upgrade Now в вылезающем сверху спойлере,или это свернёт форум?

Там предлагается обновиться до версии 4.1.5.2

Link to comment
Share on other sites

Глюк ещё какой-то при переходе со страницы на страницу,бывает очень долго ничего не грузится,а если обновить то грузит моментально....не в курсе как поправить?

Или например сохранение настроек в админке идёт долго и крутится кружок этот в центре,а на деле всё уже давно сохранено.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...