Jump to content

Глюк отображения символов при обновлении


Vasilisk
 Share

Recommended Posts

Обновил 3.4.х до 4.1.7 все символы русскими буквами написанные превратились в знаки вопроса. собственно вопрос, как и что куда крутить чтоб отображение текста вернулось к читабельному состоянию? 

1.thumb.jpg.7f524225d4b64458094677c51173

Link to comment
Share on other sites

1 минуту назад, Respected сказал:

Символы в базе нормально отображаются?

да, вроде, не везде смотрел, но то что смотрел там все ок

 

Link to comment
Share on other sites

посмотрите в phpmyadmin базу. Если в кодировке utf-8 все видно нормально, то глюки подключения. Если нет – вам не повезло. 

но, судя по скриншоту: локализация форума – верная, – вам не повезло. Проверьте в какой кодировке данные в бд. Если ???? в самой бд, – нужно брать старый бэкап бд и конверить его в utf-8.

 

Link to comment
Share on other sites

31 минут назад, Respected сказал:
7 минут назад, Андрей Усков сказал:

посмотрите в phpmyadmin базу. Если в кодировке utf-8 все видно нормально, то глюки подключения. Если нет – вам не повезло. 

но, судя по скриншоту: локализация форума – верная, – вам не повезло. Проверьте в какой кодировке данные в бд. Если ???? в самой бд, – нужно брать старый бэкап бд и конверить его в utf-8.

Ой ой ой, я бекап форума то сделал, а вот бекап базы то нет... может что то можно придумать? Потому что если ничего придумать нельзя то я походу очень очень встрял((

Link to comment
Share on other sites

Только что, Vasilisk сказал:

Ой ой ой, я бекап форума то сделал, а вот бекап базы то нет... может что то можно придумать? Потому что если ничего придумать нельзя то я походу очень очень встрял((

как делался бэкап? через панель хостинга? если да – там бд лежит.

Вы смотрели через phpmyadmin что там? хотя, не вижу смысла смотреть – у вас логины юзеров на латинице в порядке..

посмотрите таблицу  _pots. Если все в ???? то….. мне ни разу не удавалось из ??? получить нормальный текст.

Хотя, 3.* требует utf8. 

Link to comment
Share on other sites

3 минуты назад, Vasilisk сказал:

через  phpmyadmin смотрел там все ок

повезло. тогда траблы в подключении..

В свойствах обозревателя какая кодировка стоит? 

Попробуйте  в конф_глобал добавить:
$INFO['mysql_codepage']            =    'utf8';

 

Link to comment
Share on other sites

53 минут назад, Vasilisk сказал:

все вобще слетело)) даже форум...

Пипец! Ваще всё поломали)) :o Попробуйте зайти по этому адресу домен.ru/admin/convertutf8/ МОЖЕТ, что предложит!

Edited by Sipsb
Link to comment
Share on other sites

20 минут назад, Sipsb сказал:

Пипец! Ваще всё поломали)) :o Попробуйте зайти по этому адресу домен.ru/admin/convertutf8/ МОЖЕТ, что предложит!

там ломать нечему.

 

у меня эта коверташка не могла все таблица конвертнуть, вручную конвертил.

Но, на обнову 4 не пускает, если таблицы не в utf8mb4.

Обойти можно, если указать контроллер update в адресной строке

Link to comment
Share on other sites

  • 2 weeks later...
В 20.01.2016 в 23:46, Андрей Усков сказал:

там ломать нечему.

 

у меня эта коверташка не могла все таблица конвертнуть, вручную конвертил.

Но, на обнову 4 не пускает, если таблицы не в utf8mb4.

Обойти можно, если указать контроллер update в адресной строке

можно показать ссылкой этот контроллер апдейт?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...