Jump to content
hawk2012

Не устанавливается перевод целиком

Recommended Posts

Всем привет!

При установке перевода, который указан в разделе "Релизы IPS4 -> 4.1.16.1", не устанавливается целиком русский перевод форума. Произвожу установку с помощью хмлки со всеми компонентами. на версии 14 все переводилось нормально. Выглядит все примерно так:Untitled.png

В чем может быть проблема? Ubuntu 16.04, Plesk 12, MySQL 5.7.16 (платформа моя).

Share this post


Link to post
Share on other sites
3 часа назад, hawk2012 сказал:

При установке перевода, который указан в разделе "Релизы IPS4 -> 4.1.16.1", не устанавливается целиком русский перевод форума

Аналогичная проблема и у меня. Бились с @Redneck над ней, но так и не решили.

3 часа назад, hawk2012 сказал:

Ubuntu 16.04, MySQL 5.7.16

И конфигурация сервера такая же.

1 час назад, Silence сказал:

попробую помоч

Если получится, отпишитесь.

Share this post


Link to post
Share on other sites
1 минуту назад, Silence сказал:

Попробуйте : Установите перевод для 4.1.15 --- и обновите сновии версии 4.1.16.1

У меня стояла 4.1.15 с русским переводом для нее, обновил на 4.1.16.1. И перевод полностью больше не ставится, остаются фразы на английском.

Также пробовал заливать перевод на чистую установку 16.1 - руссифицируется на 10%, все остальное остается на английском.

Share this post


Link to post
Share on other sites
16 минут назад, Silence сказал:

Попробуй ето:

 

Russian (RU).xml

Проблема не в файле русификатора. При установке не выдает никаких ошибок, процесс установки проходит нормально, но быстро и ничего не устанавливается. 

Самое интересное, что я пока видел эту проблему у 2-х системных администраторов ( hawk2012 и ram108, ) :) 

ИМХО, проблема в ваших серверах, но лично я в них, в отличии от вас - полный ноль :) 

Share this post


Link to post
Share on other sites
4 часа назад, hawk2012 сказал:

Ubuntu 16.04, Plesk 12, MySQL 5.7.16 (платформа моя).

 

1 час назад, ram108 сказал:

И конфигурация сервера такая же.

Раз у вас схожие конфигурации и одинаковая проблема, значит копать надо там :) 

 

Share this post


Link to post
Share on other sites
5 минут назад, Redneck сказал:

проблема в ваших серверах

Я уже все возможные настройки перепробовал и nginx и php. Никаких сообщений об ошибках.

Сам файл с языковым пакетом загружается на сервер в полном объеме (проверено), но что с ним происходит дальше и почему он не обрабатывается должным образом - загадка. 

Могу создать тестовую установку форума 16.1 для желающих попробовать загрузить языковой пакет.

Share this post


Link to post
Share on other sites
6 минут назад, Silence сказал:

Я думаю, что это региональные настройки (Locale)

Пробовал и вручную ставить ru_RU и автоматом - результат тот же.

Снимок.PNG

Share this post


Link to post
Share on other sites

Единственный рабочий вариант на данный момент. Устанавливать 4.1.14, руссифицировать, апгрейдить до 14.1.16.1. Тогда сохранится русский язык от 14-версии. Новые строки из 16-ой не будут переведены.

Из этого делаю вывод, что косяк не в настройках сервера, а в новом баге в 16-й версии. Исправят ли его - не известно.

Share this post


Link to post
Share on other sites
1 час назад, ram108 сказал:

Единственный рабочий вариант на данный момент. Устанавливать 4.1.14, руссифицировать, апгрейдить до 14.1.16.1. Тогда сохранится русский язык от 14-версии. Новые строки из 16-ой не будут переведены.

Из этого делаю вывод, что косяк не в настройках сервера, а в новом баге в 16-й версии. Исправят ли его - не известно.

Не знаю на счет бага. я ставил одному нулл 4.1.16.1 с мафии и русифицировал версией 4.1.16 от Ильи - все прошло гладко и русик встал без проблем. Еще одному обновлял, и тоже проблем не возникло.

Да и сколько было скачек с мафии с обгрейдами и чистыми установками, а с подобной проблемой отписались только двое.

Поэтому можно разные выводы делать ;)   

Share this post


Link to post
Share on other sites
1 час назад, Redneck сказал:

с подобной проблемой отписались только двое

У всех отписавшихся о проблеме одна и та же конфигурация софта. Это тоже о многом говорит. Да и почему 14-версия встает нормально, а 16 - нет? Баг может наблюдаться например, только на Ubuntu 16.04 или php7. Когда разработчики добавляют совместимость с php7, много проблем возникает, т.к. php7 сильно отличается от php5.

В вашем случае какая версия php была?

Share this post


Link to post
Share on other sites
8 часов назад, ram108 сказал:

В вашем случае какая версия php была?

Версия PHP 5.6, в том и дело, на таком же конфиге все ставилось на ура. Причем 4.1.15 и 4.1.14 переводился, а вот 4.1.16 не захотел.

Сейчас все в порядке, но если у других пользаков такое будет то копать надо довольно глубоко. Я еще грешу на особенности системы, так как раньше стояла Plesk 12, а сейчас Plesk Onyx, версия новая.

Edited by hawk2012

Share this post


Link to post
Share on other sites
7 минут назад, slimer сказал:

На лицензии нормально перевод встал, как всегда.

Конфигурация какая программного обеспечения?

Share this post


Link to post
Share on other sites
18 часов назад, Silence сказал:

Я думаю, что это региональные настройки (Locale)

у меня при тест :

11.png

 

Разглядывая сообщение, увидел интересную фразу:

The chosen locale is not supported by your server. Your hosting provider or system administrator will be able to provide a list of the locales supported by your server.

Допуская даже региональные настройки, у меня на сервере стоят русские RU-RU-UTF8, следовательно импортироваться должен без проблем. Это доказало то, что я зашел после осмотра данного топика на козырнувший форум и увидел. что уже все русское. Только вот кто как установил не знаю.

Share this post


Link to post
Share on other sites
22 минуты назад, hawk2012 сказал:

у меня на сервере стоят русские RU-RU-UTF8

у меня тоже

22 минуты назад, hawk2012 сказал:

после осмотра данного топика на козырнувший форум и увидел. что уже все русское

но к сожалению, русский так и не встал...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×