Jump to content

zulfukar

Пользователи
  • Content Count

    21
  • Joined

  • Last visited

About zulfukar

  • Rank
    Новичок

Информация

Recent Profile Visitors

941 profile views
  1. Обновил форум с 3.4.8 до 4.1.3.2 В админке - Расширенные настройки - ЧПУ изменил вид: /forum/id-?? на /forum/id /topic/id-?? на /topic/id т.е. открыл ссылки для редактирования и в forum/{#id}-{?} и topic/{#id}-{?} удалил -{?} теперь у меня ссылки на форумы и темы имеют вид: /forum/100/ /topic/100/ но есть проблема, которую я не могу решить, так как нет ее ссылки в Расширенные настройки - ЧПУ это ссылки на другие сообщения форума, которые пользователи оставляли в своих сообщениях. К примеру у меня в одном из сообщений есть ссылка на другое сообщение вида: /forum/topic/1034/?p=46651 при клике на который она переходит по ссылке и преобразуется в /forum/topic/1034/?comment=46651 . Таким образом я попадаю на первую страницу темы, а не на нужное сообщение (т.е. ссылка срабатывает до ?comment=46651). /forum/topic/1034/?comment=46651 - ссылка получается такой /forum/topic/1034/#comment-46651 - но должна быть такой как сделать, чтобы ?comment= преобразовывалось в #comment- в Расширенные настройки - ЧПУ в самом верху есть Создать. Там наверное можно создать нужную мне ссылку, но я не знаю как. Помогите кто знает.
  2. В админке форума 3.4.8 появилось сообщение нужно ли применить этот патч?
  3. Решил отредактировать сообщение на форуме и добавить недостающую часть, просто скопировав ее с базу и вставив в сообщение. Открыл сообщение для редактирования и обнаружил, что она полная!!! Нажал на кнопку Сохранить и весь текст пропал! Обновил страницу и текст появился, но опять же до того места, что на картинке в первом сообщении. Снова открыл сообщение для редактирования и снова вижу перед собой весь текст (как в БД) и снова сохраняю его. Без результата! текст не полностью сохраняется. При редактировании добавляю что-то в текст и оно не сохраняется, выводится все тот же первоначальный текст.
  4. Обновился с 3.1.2 до 3.4.8. Через пару дней один из пользователей сообщил, что в его сообщении отсутствует част текста. Посмотрев базу я обнаружил, что текст в сообщении присутствует полностью, но на форуме отображается лишь его малая часть. Что можно с этим сделать? Возможно это не единичный случай! Как глобально все это исправить? на первой картинке сообщение в бд, которое на сайте выводится до выделенного места!!! Как видите там еще много текста присутствует.
  5. подскажите как установить код на 3.4.8 пробовал разные варианты, но не помогло. У меня папка с кодом находиться в корне сайта, где находится и сама папка /forum как к примеру в этом коде прописать путь к файлу sape.php ? абсолютный путь выглядит так: /home/*****/public_html/site.ru/хэш-код/sape.php форум находится в папке /site.ru код взял отсюда: help.sape.ru/sape/faq/1483
  6. zulfukar

    Ошибки с IPB 4

    А в 4.0.11 в админке нет функции redirect 301 для старых ссылок?
  7. Не помогло. Галочки все были. Загрузил файл и взял оттуда одну строку (остальные были). заменил эту на эту (из файла) _________________________________ На 3.4.7 все так легко получилось, а в этой версии никак не хочет работать. Вид ссылок уже никак нельзя вернуть к первоначальному (оригинальному) виду, чтобы в будущем при обновлениях не было проблем?
  8. Поставил и сделал запросы. Кириллица в ссылках изменилась на латиницу, но проблемы 404 осталась.
  9. zulfukar

    Ошибки с IPB 4

    Но дело не в типе таблиц. Вопрос был другой. А именно: Система -- Приложения -- Проверить обновления у меня вылетает ошибка EX1271 Что-то пошло не так. Пожалуйста, попробуйте еще раз. Тут писали, что проблема в кодировке, но у меня в базе все таблицы в utf8_general_ci это ошибка или нет?
  10. zulfukar

    Ошибки с IPB 4

    В чем тогда проблема? или это не проблема вовсе?!
  11. как нет ошибки 404? Вам нужно было перейти по ссылке в первом сообщении. Там вот эта ссылка 313news.net/forum2/index.php?/topic/70/ при переходе на которую открывается страница 404.
  12. zulfukar

    Ошибки с IPB 4

    Система -- Приложения -- Проверить обновления у меня вылетает ошибка EX1271 Что-то пошло не так. Пожалуйста, попробуйте еще раз. Тут писали, что проблема в кодировке, но у меня в базе все таблицы в utf8_general_ci , но я заметил, что у некоторых таблиц Тип не MyISAM а InnoDB Может ли быть проблема в этом? Стоит ли изменить Тип на MyISAM ?
  13. Извините не знал что такая тема есть. Сделал запросы. Не помогло.
  14. Здравствуйте. Обновил форум с 3.4.7 до 4.0.11. Полет нормальный. Единственная проблема в ссылках на разные темы и сообщения форума, которые пользователи оставляли в своих сообщениях. Дело в том, что я несколько лет пользовался версией 3.1.2 в которой ссылки тем форума имели вид: .../forum/index.php?/topic/840/ и после обновления до версии 3.4.7 они перестали работать (открывалась страница 404). Оказалось, что у меня был нестандартный вид ссылок. На одном из форумов мне посоветовали изменить содержимое файла ../admin/applications/forums/extensions/furlTemplates.php на это: это помогло и все ссылки оставленные в сообщениях в версии 3.4.7 заработали и стали правильно переходить. Теперь я обновил форум до последней версии 4.0.11 и также изменил содержимое файла ../admin/applications/forums/extensions/furlTemplates.php но чуда на этот раз не произошло. Помогите решить проблему. З.Ы. все обновления я делал на копии форума по ссылке 313news.net/forum2 , а оригинал все еще работает на версии 3.1.2 и доступен по ссылке 313news.net/forum Для наглядности вот ссылка на одну из тем 313news.net/forum2/topic/5461-siələrə-suallar-ii-hissə/ в первом посте которого есть ссылка на другую тему форума, при клике на которую происходит переход на стр.404 Предупреждение! Ссылки на новом/обновленном форуме старые и ведут на страницы оригинального форума. В этих ссылках нужно изменять название папки /forum на /forum2 . тоесть ссылка в первом посте этой темы будет такого вида: 313news.net/forum2/index.php?/topic/70/
  15. zulfukar

    IPS Community Suite 4 - Nulled

    У Вас в файле \applications находится архив applications.zip он случайно туда попал или должен там быть?
×