Jump to content

Локализация IP.Board 3.4.7 (Включая настройки)


Cheshir
 Share

Recommended Posts

Название: Локализация IP.Board 3.4.7 (Включая настройки)

Добавил: Cheshir

Добавлен: 25 Дек 2014

Категория: Локализация IP.Board

 

Локализация IP.Board 3.4.7

 

1. Загрузить файл language_ru.xml.gz при помощи панели администратора Внешний вид > Языки > Импортирование XML-файла.

 

2. Открыть в редакторе (Notepad++ или аналогичный) файл language_settings sql.txt, изменить ВСЕ префексы таблиц с "pjr_" на свой (обязательно!). Скопировать все и запустить через панель phpMyAdmin (вкладка SQL), или через панель администратора IP.Board (Поддержка > Управление SQL > Инструменты управления SQL, в конце страницы).

 

Link to comment
Share on other sites

изменить ВСЕ префексы таблиц с "pjr_" на свой (обязательно!).

не могу сообразить, а как узнать свой префикс? :facepalm:

Link to comment
Share on other sites

  • 3 weeks later...

зайти в БД и посомотреть

у меня вообще префикса нет. Если я правильно понимаю, что под этим подразумевается. Например у phpbb, префикс phpbb_ в базе..

Link to comment
Share on other sites

да, правильно понимаете, значит удаляете его, скорее всего так, не знаю, я предпочитаю 3.4.6

Link to comment
Share on other sites

Стили встают криво ссылка

Причем тут стили? это локализация, а не тема.

Link to comment
Share on other sites

  • 5 weeks later...

Спасибо парни

Локализацию поставила (оф. 3.4.7)

Правда без танцев с бубном не обошлось (так как не имею доступа к админ-панели хостинга и ftp)

Но вот одно, "но" Заглавная буква "И" - стоит коряво (как будто ошибка в кодировке UTF-8 только в одной букве

Может, возможно как-то исправить через админку? Ткните носом, куда зайти и какую строку в локализации подправить

Edited by WOLF
Link to comment
Share on other sites

Спасибо парни

Локализацию поставила (оф. 3.4.7)

Правда без танцев с бубном не обошлось (так как не имею доступа к админ-панели хостинга и ftp)

 

Для этого вам не нужен фтп. Средствами IPB делает на вкладке управление БД или SQL, не помню как точно называется, внизу страницы.

 

 

Но вот одно, "но" Заглавная буква "И" - стоит коряво (как будто ошибка в кодировке UTF-8 только в одной букве

Может, возможно как-то исправить через админку? Ткните носом, куда зайти и какую строку в локализации подправить

 

К сожалению, это не в переводе дело, а в кодировке вашей БД. Ищите темы, где люди приводят к единообразному виду кодировки (желательно в utf8).

если форум с 0 ставите, проще удалить БД и создать новую в кодировке utf8, а после устанавливать форум и русификацию.

Link to comment
Share on other sites

После танцев с бубном удалось поставить локализацию.

Оказалось, что проблеме "ш", "Ш", "И" в UTF-8 кодировке не один день.

В моем случае, как выяснилось, то в самом движке по умолчанию вообще стояла ISO-кодировка

 

P.S.

Некоторые моменты в админке все равно не переведены. Видимо забыли :-)

Link to comment
Share on other sites

P.S.

Некоторые моменты в админке все равно не переведены. Видимо забыли :-)

 

Табы не переводил умышленно, может что то и забыл/не увидел. Дорабатываться не будет язык, переключаюсь на 4ю версию

Link to comment
Share on other sites

  • 2 weeks later...

Названия вкладок Forums, Members у меня не переводятся почему-то, но не в админке а на главной.


И что самое интересное, я не могу их найти непереведенными нигде. Версия 3.4.7

Edited by lmaolmao
Link to comment
Share on other sites

lmaolmao,  =) Конечно, можно еще поискать, но с подсказкой будет проще... Перевести названия вкладок можно в Управление Приложениями -> Настройки

Link to comment
Share on other sites

lmaolmao,  =) Конечно, можно еще поискать, но с подсказкой будет проще... Перевести названия вкладок можно в Управление Приложениями -> Настройки

 

Спасибо , добрый человек.

Link to comment
Share on other sites

  • 4 weeks later...

Доброго времени суток! У меня проблема с отображением буквы "И". Может проблема решена но я ничего не нашел. В настройках кодировка по умолчанию стоит UTF-8, в базе данных стоит utf8_general_ci. Не могу понять как решить проблему. Нужно менять кодировку базы данных, если да то на какую и как? Сайт на денвере

Link to comment
Share on other sites

Доброго времени суток! У меня проблема с отображением буквы "И". Может проблема решена но я ничего не нашел. В настройках кодировка по умолчанию стоит UTF-8, в базе данных стоит utf8_general_ci. Не могу понять как решить проблему. Нужно менять кодировку базы данных, если да то на какую и как? Сайт на денвере

 

Не берусь судить о влиянии работы IPB с денвера на возникновение таких ошибок в БД, но для себя бы я привел все таблицы к единообразию. Как это сделать? Муторно, руками, каждую таблицу!) Хотя, можно найти и полуавтоматический режим, попробуйте следующее:

 

Откройте в PHPmyAdmin требуемую базу данных, а затем перейдите в раздел sql запросов, там выполните запрос следующего кода:

Заменить кодировки (если требуется) и название БД

SELECT CONCAT('ALTER TABLE `', t.`TABLE_SCHEMA`, '`.`', t.`TABLE_NAME`, '` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;') as sqlcode
  FROM `information_schema`.`TABLES` t
 WHERE 1
   AND t.`TABLE_SCHEMA` = 'Указать название БД'
 ORDER BY 1

Полученные запросы вновь обработать SQL
Link to comment
Share on other sites

 

Не берусь судить о влиянии работы IPB с денвера на возникновение таких ошибок в БД, но для себя бы я привел все таблицы к единообразию. Как это сделать? Муторно, руками, каждую таблицу!) Хотя, можно найти и полуавтоматический режим, попробуйте следующее:

 

Откройте в PHPmyAdmin требуемую базу данных, а затем перейдите в раздел sql запросов, там выполните запрос следующего кода:

Заменить кодировки (если требуется) и название БД

SELECT CONCAT('ALTER TABLE `', t.`TABLE_SCHEMA`, '`.`', t.`TABLE_NAME`, '` CONVERT TO CHARACTER SET utf8 COLLATE utf8_general_ci;') as sqlcode
  FROM `information_schema`.`TABLES` t
 WHERE 1
   AND t.`TABLE_SCHEMA` = 'Указать название БД'
 ORDER BY 1

Полученные запросы вновь обработать SQL

Хочется вас поругать но сдержусь)) сделал все не помогло))

Link to comment
Share on other sites

Хочется вас поругать но сдержусь)) сделал все не помогло))

Вы себя ругайте, и смотрите настройки своего сервера и БД. Либо ищите в просторах интернета решения данной проблемы, проблема известная, не связанна ни с движком, ни с локализацией, проблема с вашим мускулом и бд. Смотрите настройки соответствия полей в БД. Если есть возможность, протестируйте на нормальном сервере.

Link to comment
Share on other sites

Вы себя ругайте, и смотрите настройки своего сервера и БД. Либо ищите в просторах интернета решения данной проблемы, проблема известная, не связанна ни с движком, ни с локализацией, проблема с вашим мускулом и бд. Смотрите настройки соответствия полей в БД. Если есть возможность, протестируйте на нормальном сервере.

Сделаю проще! Возьму и поставлю 3.4.6. У многих проблема такая возникала, но никто не написал как ее решил

Link to comment
Share on other sites

Сделаю проще! Возьму и поставлю 3.4.6. У многих проблема такая возникала, но никто не написал как ее решил

А у МНОГИХ не возникла. Вы откуда релиз скачивали? В сети полно вот таких:

post-24610-0-64631800-1427629239_thumb.j

У релиза, скачанного отсюда, и с данной локализацией проблем нет. У многих ))

 

Вот кстати похожая ошибка на 3.4.6: 

А вот на 3.4.5: '?do=embed' frameborder='0' data-embedContent>>

А вот даже на 3.1_ipbskins.ru/forum/topic6215.html

и еще_forums.ibresource.ru/topic/65176-posle-obnovleniia-ipb-332--345-bukva-i-vezde-zamenila/

 

Решения нет? плохо искали.

 

Вы себя ругайте, и смотрите настройки своего сервера и БД. Либо ищите в просторах интернета решения данной проблемы, проблема известная, не связанна ни с движком, ни с локализацией, проблема с вашим мускулом и бд. Смотрите настройки соответствия полей в БД. Если есть возможность, протестируйте на нормальном сервере.
Link to comment
Share on other sites

Доброго времени суток.

Поставил локализацию на лицензионный 3.4.7

С установкой проблем не возникло, форум изначально ставился с кодировкой ядра и базы utf-8.

 

ПРОБЛЕМА:

При включении русской  версии не регистрируются пользователи с русскими именами (пишет ,что такое имя уже занято), если переключиться на английскую версию (просто внизу форума сменить язык) - пользователь с русским именем регистрируется без проблем.

Подскажите пожалуйста, где копать?

Link to comment
Share on other sites

Bard, К сожалению с такой проблемой не встречался. Полагаю, что это индивидуальная проблема, раз только вы ее озвучиваете и ответа у меня нет...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...