Jump to content

c 3.4.9 на 4.1.6.1 не пускает обновляться


Xuc
 Share

Recommended Posts

в начале обновления на 4.1.6.1 тупо говорит что не правильные логин или пасс

хотя тут же поднимаю обратно 3.4.9 - логин и пасс подходят

куда копать?

Link to comment
Share on other sites

Никуда. Только что в чате ИПС такая же жалоба была. Если повезёт, то исправят в 4.1.7. Завтра разрабы будут изучать эту проблему. По крайней мере так сказали.

Edited by Sanshalay
Link to comment
Share on other sites

А сразу с 3.4.8 перейти на 4-ку нельзя было? Как вариант, сделать даунгрейд на 3.4.8 и обновится на 4-ку, но это далеко очень не просто.

Link to comment
Share on other sites

сделал даунгрейд на 3.4.8, обновил кэши, убрал логи сессий обновлений, все равно проблема осталась)))

куда копать?

вся фигня в том что я уже обновлял этот форум на 4.1.2 без проблем 

Link to comment
Share on other sites

Как делал даунгрейд? Я лично с таким не сталкивался, и все форумы что я обновлял на 4-ку, они были не старше чем 3.4.6. Что было на 3-ке после этого, я хз.

Я бы на твоем месте попробовал штатными средствами сменить пароль, или даже завечти отдельную учетку-админа новую, что бы из-под нее обновить, после перевести ПХП на 5.6 (если после этого не будет работать форум - игнорируй, 4-ка с ним нормально работает, даже на этапе обновления), проверил что вся БД и таблицы в UTF8 (иначе конвертировать), и потом еще раз попробовать апгрейд сделать.

Link to comment
Share on other sites

даунгрейд делал так: восстановил БД месячной давности и поверх залил скрипты ipb 3.4.8

восстановил и сменил пасс, проверил! потом залил ips4.1.7 

Link to comment
Share on other sites

@Xuc если сильно хочется обновиться, и нечем заняться, можешь еще попробовать не сразу на 4.1.7, а на что-то из 4.0.Х версии. Я форумы до 3.4.6 и младше обновлял как раз на 4.0.Х, что было успешно.
 Но и на них почти не было хуков/дополнений... Может твоя проблема в них и кроется...

Link to comment
Share on other sites

я с 2.4 обновлялся так:

  • смена в редакторе кодировки  на utf-8
  • скачек на 3.0.*
  • обнова на 3.4
  • затем на 4.1

Такую ошибку имел из-за неверной кодировки базы данных. По сути, я убрал проверку аутентификации и обновился.

проблема непрохождения аутентификации именно в бд, т.к. запись сессии идет в базу.

если хочешь – могу попробовать обновить.  Дай бэк-ап. Я, с 2.4.6 полгода отрабатывал схему обновы форума  с 3Гб бд. Начинал обнову с недели, и закончил с 2.4.6 на 4.1 за 6 часов + конвертация постов за 3 дня.

 

Кстати,  думайте перед обновой до 4, т.к у меня с тройки бд выросла на гиг:

на 2.6 – 2.4 Гб

на 3.* – 3.6 Гб

на 4.1.6 – 4.2 Гб.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...