Jump to content

Смайлики и SSL не дружат


slimer
 Share

Recommended Posts

Если у вас форум работает по https, то при вставке смайлика кликом (выбор из списка) - всё ок. Если смайлик преобразуется автоматом, скажем из

:)

То картинка вставляется по протоколу http

Как вылечить?

Link to comment
Share on other sites

Увы у меня не удалось воспроизвести проблему. Смайлики открываются по https. Может у вас не дефолтный набор?   

Link to comment
Share on other sites

А причем тут http и SSL? Смайлы хранятся на сервере, следовательно грузятся с него. Возможно, пути неправильно настроены.

Link to comment
Share on other sites

3 минуты назад, Ден Сакурен сказал:

Может у вас не дефолтный набор?   

Набор не дефолтный, но он же загружен на сервер и при вставке смайлика кликом всё нормально. Дело именно в автоматическом преобразовании.

1 минуту назад, hawk2012 сказал:

Возможно, пути неправильно настроены.

Пути какие и где еще могут использоваться? См. предыдущий ответ.

Link to comment
Share on other sites

Только что, slimer сказал:

Набор не дефолтный, но он же загружен на сервер и при вставке смайлика кликом всё нормально. Дело именно в автоматическом преобразовании.

Пути какие и где еще могут использоваться? См. предыдущий ответ.

Бывает такая особенность что настраиваются разные папки для ssl и http, а читается из одной. Отсюда и чтение по http, я это имею в виду :)

Link to comment
Share on other sites

Только что, hawk2012 сказал:

Бывает такая особенность что настраиваются разные папки для ssl и http, а читается из одной. Отсюда и чтение по http, я это имею в виду :)

В настройках веб-сервера? Нет, это тут не при чем. Выводом смайликов форум рулит.

Link to comment
Share on other sites

Только что, slimer сказал:

В настройках веб-сервера? Нет, это тут не при чем. Выводом смайликов форум рулит.

Нет, это не настройки, а папки, ну как бы сказать: форум например в public_html, а ssl public_https, как-то так. Либо автоопределение SSL корректно не работает.

Link to comment
Share on other sites

Я думаю дело в парсере, правда беглый осмотр ничего не дал. Интересно как у других работает и на каких версиях. У меня 4.1.10

20 минут назад, Ден Сакурен сказал:

Увы у меня не удалось воспроизвести проблему

Какая версия у тебя?

Link to comment
Share on other sites

4 минуты назад, slimer сказал:

Я думаю дело в парсере, правда беглый осмотр ничего не дал. Интересно как у других работает и на каких версиях. У меня 4.1.10

Какая версия у тебя?

4.1.15 Дефолтные смайлы.

Link to comment
Share on other sites

А можно ссылку на форум?

46 минут назад, slimer сказал:

Если у вас форум работает по https, то при вставке смайлика кликом (выбор из списка) - всё ок. Если смайлик преобразуется автоматом, скажем из


:)

То картинка вставляется по протоколу http

Как вылечить?

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...