Jump to content
Sign in to follow this  
seobot

Слэш в конце URL

Recommended Posts

После обновления начал появляться слэш в конце URLa.

http://site.ru/forum25.html/

http://site.ru/topic25.html/

Что ара, начинает жрать дубли Яндекс. Открывает страницу как со слэшэм так и без. Редирект то я сделаю через роботс чтобы слеш убирал, НО как его убрать вообще? В Настройках ЧПУ все стоит как и было.

Share this post


Link to post
Share on other sites
42 минуты назад, seobot сказал:

Редирект то я сделаю через роботс чтобы слеш убирал, НО как его убрать вообще?

что это роботс :

Включит Rewrite URLs и поставит ето файл в корен ваш форум:

 

htacces.s

Share this post


Link to post
Share on other sites

 

В 18.11.2016 в 21:43, seobot сказал:

Ищите проблему там, где вы получаете такие URL. Скорее всего этот последний слеш там и прописан.

Share this post


Link to post
Share on other sites
22 часа назад, ram108 сказал:

 

Ищите проблему там, где вы получаете такие URL. Скорее всего этот последний слеш там и прописан.

Это я знаю. А где ее искать то??

Share this post


Link to post
Share on other sites

АП помогите решить проблему, весь форум перерыл, эта фигня стала после какого то апдейта. Я сардельками не лазил никуда....

Edited by seobot

Share this post


Link to post
Share on other sites
13 минут назад, seobot сказал:

АП помогите решить проблему, весь форум перерыл, эта фигня стала после какого то апдейта. Я сардельками не лазил никуда....

Если нет проблем - дайте мне админ права .... я посматрю

Share this post


Link to post
Share on other sites
16 минут назад, seobot сказал:

АП помогите решить проблему, весь форум перерыл, эта фигня стала после какого то апдейта. Я сардельками не лазил никуда....

После апдейта на 4.0, ога.

Начиная с 4-ой версии ко всем ссылкам IPS добавляется слэш. И по-моему это не убирается, если плагин не помог (вам выше кидали)

Share this post


Link to post
Share on other sites

Нет, это случилось недавно, в ноябре. До этого в 4ке всё было нормально у меня.

Edited by seobot

Share this post


Link to post
Share on other sites

чего-то не вижу слэшей у себя на главной. Только в темах и подфорумах, что не критично в принципе. ТС хоть бы ссылку на свой форум дал, а то сиди пальцем в небо тыкай.

Share this post


Link to post
Share on other sites
16 часов назад, seobot сказал:

Нет, это случилось недавно, в ноябре. До этого в 4ке всё было нормально у меня.

Я могу с полной уверенностью сказать, что началось это с четвёрки.

Через несколько дней после релиза 4-ки появился плагин с названием "Fix annoying slash", который убирал слеши в конце ссылок.

Разработчики с момента релиза точно в этой области ничего не меняли.

Share this post


Link to post
Share on other sites
В 04.01.2017 в 14:36, rustav сказал:

у тебя на всех страницах имеется .html/  кроме профилей.  Копай в эту сторону. Возможно с .htaccess чего-то начудил.

В htaccess всё по дефолту как и было))

Share this post


Link to post
Share on other sites

Я думаю, что "свет в конце туннеля" (все время ловлю себе на том, что читаю название темы именно так), вшит в ядро форума. Скорее всего легко от него не избавиться, нужно смотреть код и внимательно изучать тему.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×