Jump to content

При перемещении тем в открывшемся списке форумов не раскрывается вложенные разделы


sergey81
 Share

Recommended Posts

При перемещении тем в открывшемся списке форумов не раскрывается вложенные разделы. Смотри на картинке во вложении.

Все отлично работало до того момента, пока в админке не произвели слияние и совмещение некоторых тем форума. После этого,

модератору открывается список разделов форума для выбора перемещения нужных тем, но список не  раскрывается, а висит в состоянии буд-то

список разделов подгружается. Права доступа проверены - все верно. Что за глюк? как исправить? кто сталкивался?

Спасибо за любые подсказки!

Снимок экрана от 2019-02-13 04-54-46.png

Link to comment
Share on other sites

Перед тем, как открыть вложенные разделы, нажмите F12, вкладку Network, жмите. Уходит запрос на сервер, должен вернуть json. Скорее всего возвращает ошибку.

Link to comment
Share on other sites

2 часа назад, Respected сказал:

Версия форума? 

Invision Community v4.2.7

2 часа назад, Desti сказал:

Перед тем, как открыть вложенные разделы, нажмите F12, вкладку Network, жмите. Уходит запрос на сервер, должен вернуть json. Скорее всего возвращает ошибку.

красным запрос выделен как раз в момент  нажатия на раскрытие списка нужных тем. что и где сломано?

Снимок экрана от 2019-02-13 23-30-26.png

ахаха...  сейчас аналогичную процедуру выполнил на локальной тестовой системе, и браузер выдал аналогичное подвисание при раскрытии списка. не пойму - в браузере что ли глюк или что за ерунда.

Link to comment
Share on other sites

Была такая же проблема, не нашёл пути решения, кроме как переустановкой форума(

Хотя, тогда я даже не задумывался о том, чтобы написать сюда и попросить помощи. 

Link to comment
Share on other sites

 

2 часа назад, sergey81 сказал:

что и где сломано?

Этого вам никто не скажет, надо лезть в код, искать причину ошибки. У меня подобное закончилось обнаружением кривой конвертации в таблице лайков, прилетала ошибка при попытке поставить реакцию. Причем кривой проверяльщик базы ошибку не видел :(

Link to comment
Share on other sites

2 часа назад, Desti сказал:

 

Этого вам никто не скажет, надо лезть в код, искать причину ошибки. У меня подобное закончилось обнаружением кривой конвертации в таблице лайков, прилетала ошибка при попытке поставить реакцию. Причем кривой проверяльщик базы ошибку не видел :(

Да ну... дичь какая-то. Склонен больше думать о не корректной работе с Java апплетом на самом Пк. Поясню: 

1: даже в ново инсталлируемом тестовом форуме та же фигня! 

2: с разных браузеров одного компьютера аналогичное подвисание со списком тем форума.

3. Залез на сайт Java.com нажал проверить  установлена ли джава машина - и везде ошибка.... у Firefox что он впредь не поддерживает версии ниже 5х а в хром браузере сообщение о том что не поддерживает решения napi и papi для линукс интегрированных.

скорее всего загвоздка с локальным Пк у меня. Но другой нет системы что бы проверить с работающей на 100% java машиной. 

- У кого работает и открывается список тем форума для переноса нажмите F12 и сообщите скрин что вообще должно выдавать в логах при нормальной работе??? 

- Да и ещё грешу на возможно не корректные права доступа к каталогу /upload/java-global/    В котором находятся сами скрипты которые вызываются при раскрытии списка тем форума. 

Жду ваших советов и помощи.

Link to comment
Share on other sites

Когда вы жмете на "развернуть", срабатывает скрипт, который формирует и отправляет запрос на сервер. Если запрос отправляется, то со скриптами всё в порядке. А папку в upload создает движок, так что с правами всё нормально должно быть.  Ткните мышой в красную строку с ошибкой, что там на закладке Response?

Формируется запрос 

https://www.disney.com/topic/218/?csrfKey=8ef3...&do=multimodComment&page=1&multimod[413]=1&modaction=split&_nodeSelectName=topic_container&_nodeSelect=children&_nodeId=27&csrfKey=8ef3...

В ответ приходит json строчка со списком подкатегорий,  но это, в данном случае, не важно, у вас вообще ничего не приходит. 

4 часа назад, sergey81 сказал:

установлена ли джава машина

Она-то тут при чем? :) javascript и java - ну совсем разные вещи. 

Если форум честно купленный - тикет разработчикам отправить, пусть ковыряются. 

Link to comment
Share on other sites

Я подозреваю, что проблема в версии комьюнити. Если бы у меня был доступ в админку, я бы изучил проблему. А так рекомендую обновить до актуальной версии.

Link to comment
Share on other sites

  • 2 weeks later...

проблема кстати решена!

помог вот такой анализ. который указал что проблема с доступом ... видимо к месту или скрипта или файла который так или иначе связан за 

модуль модерации тем и разделов.

в данном случае виновный был файл .htpaccess в нем была блокировка

но это специфика нашего сервера. у нас правил просто в нем больше чем в стандартном от IPS .

закрывать тему можно!

 

350170958_2019-02-2201-14-39.thumb.png.5eb71378ef3da9fce17b2202137cf439.png

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...