Jump to content

Ошибка при добавлении статьи в базу данных


azz2

Recommended Posts

Здравствуйте!
Создаю новую базу данных, закрепляю ее к страничке.

После, пытаюсь добавить статью. Заполняю все поля, жму *Сохранить*, а в место записи получаю белый экран с ошибкой:
 

Страница недоступна

Сайт  выполнил переадресацию слишком много раз.

ERR_TOO_MANY_REDIRECTS
Link to comment
Share on other sites

azz2 Покажите фай .htaccess должно быть примерно так.

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

 

Link to comment
Share on other sites

В 03.07.2019 в 02:03, Sipsb сказал:

azz2 Покажите фай .htaccess должно быть примерно так.


<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

 

#RewriteEngine On
#RewriteCond %{REQUEST_URI} !^/robots\.txt$
#RewriteCond %{HTTP:X-Forwarded-proto} !^https$
#RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

В 02.07.2019 в 20:54, accop сказал:

Дай ссылку, зарегаюсь, проверю

Со старыми базами данных все ок, а вот при добавлении новых - ничего не работает.

Link to comment
Share on other sites

22 часа назад, Sipsb сказал:

Замените htaccess на тот, что я указал. 

Здравствуйте!
К сожалению, ничего не изменилось.

Link to comment
Share on other sites

П.С. после возврата в категорию (статей), они на титульной страничке отображаются. А как только кликнешь по одной из статеек, снова срабатывает ошибка (что написана в самом начале).

Link to comment
Share on other sites

9 минут назад, Respected сказал:

Тема/шаблоны статей стандартные? Приложения/плагины отключены?

Не отключал еще. 
Посмотрел логи ошибок за последние дни и вот что:

 

SELECT `primary_id_field`, `field_`, `member_id`, `record_comments`, `record_reviews`, `category_id`, `record_static_furl`, `record_dynamic_furl`, `record_image` FROM `cms_custom_database_10` WHERE ( primary_id_field IN(3,2,1) )
IPS\Db\Exception: Unknown column 'field_' in 'field list' (1054)
#0 /home/httpd/vhosts/site.ru/httpdocs/system/Db/Select.php(373): IPS\_Db->preparedQuery('/*IPS\\Content\\S...', Array, true)
#1 /home/httpd/vhosts/site.ru/httpdocs/system/Db/Select.php(271): IPS\Db\_Select->runQuery()
#2 /home/httpd/vhosts/site.ru/httpdocs/system/Content/Search/Results.php(170): IPS\Db\_Select->setKeyField('primary_id_fiel...')
#3 /home/httpd/vhosts/site.ru/httpdocs/applications/core/modules/front/members/profile.php(241): IPS\Content\Search\_Results->init(true)
#4 /home/httpd/vhosts/site.ru/httpdocs/system/Dispatcher/Controller.php(96): IPS\core\modules\front\members\_profile->manage()
#5 /home/httpd/vhosts/site.ru/httpdocs/applications/core/modules/front/members/profile.php(73): IPS\Dispatcher\_Controller->execute()
#6 /home/httpd/vhosts/site.ru/httpdocs/system/Dispatcher/Dispatcher.php(152): IPS\core\modules\front\members\_profile->execute()
#7 /home/httpd/vhosts/site.ru/httpdocs/index.php(13): IPS\_Dispatcher->run()
#8 {main}

В общем, очень много ошибок появляться при переходе на (просмотр профиля пользователя), вкладка /discover и тд. и тп. это конфликт с шаблоном видимо? и все оно взаимосвязано?

Link to comment
Share on other sites

4 часа назад, azz2 сказал:

IPS\Db\Exception: Unknown column 'field_' in 'field list' (1054)

Либо в БД что-то отлетело, либо неправильный запрос генерируется 

Link to comment
Share on other sites

3 часа назад, accop сказал:

Либо в БД что-то отлетело, либо неправильный запрос генерируется 

Все само заработало... Не знаю что за магия =/
А вот с базой данных pages, до сих пор ничего не изменилось

Link to comment
Share on other sites

Старые базы работают нормально. Новые вообще не хотят работать =(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...