Jump to content

HTTP Error 500 при установке


Recommended Posts

Пытаюсь ставить ipb 4.5.4, однако после залива файлов и перехода по admin/install (да и по любому другому адресу) выпадает HTTP ERROR 500. Сам форум находится в подкаталоге /forum, основной сайт работает без проблем. 
php 7.3
nginx 1.18

Link to comment
Share on other sites

FrostDelta123  так а Вы переходите по site.ru/admin/install или site.ru/forum/admin/install ? По идее, если Вы залили файлы на сервер, то при переходе по ссылку site.ru/forum должна страница установки открыться сама.

Возможно, есть смысл написать хостинг-провайдеру, может на их стороне проблема.

Link to comment
Share on other sites

1 минуту назад, Elhombre сказал:

FrostDelta123  так а Вы переходите по site.ru/admin/install или site.ru/forum/admin/install ? По идее, если Вы залили файлы на сервер, то при переходе по ссылку site.ru/forum должна страница установки открыться сама.

Возможно, есть смысл написать хостинг-провайдеру, может на их стороне проблема.

Да, я перехожу именно по forum/admin/install, просто ошибся в топике. Что так, что просто /forum - HTTP error 500

Link to comment
Share on other sites

4 минуты назад, FrostDelta123 сказал:

Да, я перехожу именно по forum/admin/install, просто ошибся в топике. Что так, что просто /forum - HTTP error 500

Попробуйте для начала написать своего провайдеру, зачастую многие вопросы решаются на их стороне, в особенности по части ошибок.

Link to comment
Share on other sites

1 час назад, orbipwn сказал:

Show error logs.

Вижу ошибку такого рода
 

2020/11/21 01:37:32 [error] 80002#80002: *104259 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Error: Call to undefined function IPS\mb_internal_encoding() in /home/www/sv.ru-m.org/www/forum/init.php:541
Stack trace:
#0 /home/www/sv.ru-m.org/www/forum/init.php(1370): IPS\IPS::init()
#1 /home/www/sv.ru-m.org/www/forum/index.php(12): require_once('/home/www/sv.ru...')
#2 {main}
  thrown in /home/www/sv.ru-m.org/www/forum/init.php on line 541" while reading response header from upstream, client: 185.191.171.24, server: sv.ru-m.org, request: "GET /forum/index.php?%2Flanguage%2F&csrfKey=a7a388015ff6a3274a06d784bb7753e8 HTTP/1.1", upstream: "fastcgi://unix:/run/php/php7.3-fpm.sock:", host: "sv.ru-m.org"

 

Link to comment
Share on other sites

23 минуты назад, Desti сказал:

Нет расширения php-mbstring, трясите провайдера. Или сами,  apt install php7.3-mbstring

Спасибо, установил php7.3-mbstring сам, помогло

Link to comment
Share on other sites

25 минут назад, FrostDelta123 сказал:

Спасибо, установил php7.3-mbstring сам, помогло

+ человеку не забудь поставить ) 

Link to comment
Share on other sites

6 минут назад, AnWey сказал:

+ человеку не забудь поставить ) 

Видимо у меня нет прав

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...