Jump to content

Ошибка в админку при попытке оставить пост


 Share

Recommended Posts

На некоторых юзерах появилась проблема, при попытке оставить пост идет долгая загрузка ~10 секунд, после этого пост оставляется в теме, но в профиле пусто, в последних постах пусто.

В админке ошибка (у всех полностью идентичная):

IPS\Http\Request\CurlException: https://wns2-db5p.notify.windows.com/w/?token=BQYAAABphvs35TMxFfJbfYvxJRaHmTNHW7hyfap3jy5o8A018VQVUMmpdekXyZ%2beIw8gwMxBHfYvrMLGZB3BgrhPkoSujSSzdsHpn7d%2bLiDlRcjQMnDiUsDy%2fcPJZCVrAFl0pls8pjbuFICSFS7astx1x87blr90U7Zv2LR%2bkukycXxAKR%2bPCKTe3Wq9V2pDpOLU756jNpEPYrSgfKMT3DhbUlSDLzOn6WEmHk2WOkv%2fQw0cIR38V3t1zip8SlgaiyE9gkJOIgM%2bJseFqrWmxsmNSlAnrya3tSGaS6uIbH3e5AmUqMnlS8Nnrh%2baju%2fvk4m6a3TuNiWGk0Di1w4Wr50UB9M9
Connection timed out after 10001 milliseconds (28)
#0 /home/c/cd29842/forum/public_html/system/Http/Request/Curl.php(422): IPS\Http\Request\_Curl->_execute()
#1 /home/c/cd29842/forum/public_html/system/Http/Request/Curl.php(317): IPS\Http\Request\_Curl->_executeAndFollowRedirects('POST', '2~\xE0\xD0\x01\xA2c\xE6\xC0\xED\x7F\xCF\xA7\xF3\xDF...')
#2 /home/c/cd29842/forum/public_html/system/Notification/Notification.php(1133): IPS\Http\Request\_Curl->post('2~\xE0\xD0\x01\xA2c\xE6\xC0\xED\x7F\xCF\xA7\xF3\xDF...')
#3 /home/c/cd29842/forum/public_html/system/Notification/Notification.php(975): IPS\_Notification::sendPWANotifications(Array)
#4 /home/c/cd29842/forum/public_html/system/Notification/Notification.php(901): IPS\_Notification->sendPushNotifications(Array)
#5 /home/c/cd29842/forum/public_html/system/Content/Content.php(2075): IPS\_Notification->send(Array)
#6 /home/c/cd29842/forum/public_html/system/Content/Content.php(2027): IPS\_Content->sendNotificationsBatch(0, Array)
#7 /home/c/cd29842/forum/public_html/system/Content/Comment.php(241): IPS\_Content->sendNotifications()
#8 /home/c/cd29842/forum/public_html/applications/forums/sources/Topic/Post.php(130): IPS\Content\_Comment::create(Object(IPS\forums\Topic), '<p>\n\t5 \xD1\x87\xD0\xB0\xD1\x81\xD0\xBE...', false, NULL, NULL, Object(IPS\Member), NULL, NULL, NULL, NULL)
#9 /home/c/cd29842/forum/public_html/system/Content/Item.php(4781): IPS\forums\Topic\_Post::create(Object(IPS\forums\Topic), '<p>\n\t5 \xD1\x87\xD0\xB0\xD1\x81\xD0\xBE...', false, NULL, NULL, NULL, NULL, NULL, NULL, NULL)
#10 /home/c/cd29842/forum/public_html/system/Content/Item.php(4580): IPS\Content\_Item->processCommentForm(Array)
#11 /home/c/cd29842/forum/public_html/applications/forums/modules/front/forums/topic.php(133): IPS\Content\_Item->commentForm()
#12 /home/c/cd29842/forum/public_html/system/Dispatcher/Controller.php(101): IPS\forums\modules\front\forums\_topic->manage()
#13 /home/c/cd29842/forum/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#14 /home/c/cd29842/forum/public_html/applications/forums/modules/front/forums/topic.php(39): IPS\Content\_Controller->execute()
#15 /home/c/cd29842/forum/public_html/system/Dispatcher/Dispatcher.php(153): IPS\forums\modules\front\forums\_topic->execute()
#16 /home/c/cd29842/forum/public_html/index.php(13): IPS\_Dispatcher->run()
#17 {main}

Если создать нового юзера и попробовать оставить пост - все ок. Встречается на единичных юзерах.

Не подскажете, что может быть? IPS 4.6.5.1.

Link to comment
Share on other sites

9 минут назад, tatowka сказал:

Не подскажете, что может быть?

Там же все написано, класс curl выбросил ошибку (Время ожидания соединения истекло через 10001 миллисекунду (28)) при отправке запроса на https://wns2-db5p.notify.windows.com
что-то с уведомлениями, смотрите плагины\приложения которые их затрагивают

Link to comment
Share on other sites

 

3 минуты назад, Exception сказал:

Там же все написано, класс curl выбросил ошибку (Время ожидания соединения истекло через 10001 миллисекунду (28)) при отправке запроса на https://wns2-db5p.notify.windows.com
что-то с уведомлениями, смотрите плагины\приложения которые их затрагивают

Я понимаю, ссылка нерабочая даже если пытаться открыть ее в браузере.

Плагинов и приложений не установлено, уже все в АЦ перерыл, пусто. Не понимаю откуда она вообще взялась.

Вот модули:
image.thumb.png.bb8abc86a8bdfda9855d5ae97bc9110a.png

Edited by tatowka
Link to comment
Share on other sites

ошибка вызывается PWA приложением, скорее всего это баг, возможно решен в следующих версиях ips, не смотрел

Link to comment
Share on other sites

15 часов назад, Exception сказал:

ошибка вызывается PWA приложением, скорее всего это баг, возможно решен в следующих версиях ips, не смотрел

это реально как-то пофиксить? или только обновление движка?

Link to comment
Share on other sites

Есть подозрение, что хостинг ваш из дешевых (shared или шаред), даже не VDS. Соответственно, "На некоторых юзерах появилась проблема", потому что иногда физических ресурсов хватает, иногда не хватает.

Link to comment
Share on other sites

19 минут назад, Zero108 сказал:

Есть подозрение, что хостинг ваш из дешевых (shared или шаред), даже не VDS. Соответственно, "На некоторых юзерах появилась проблема", потому что иногда физических ресурсов хватает, иногда не хватает.

Дело не в хосте, а в том, что форум пытается открыть недоступную ссылку, которая не откроется даже если ты сам попробуешь ее открыть у себя в браузере. Хост проверен временем, таймвеб. Рядом стоит еще один форум, там все окей.

 

PS. Обновился до 4.7.6, проблема осталась

Edited by tatowka
Link to comment
Share on other sites

Ну, отключи авторизацию через сервисы майкрософт и вообще отключи любые сторонние авторизации, также попробуй удалить всё стороннее (например, счетчики статистики и сторонние темы). Невозможно ничего сказать далее без ссылки на сам ресурс.

Edited by Zero108
Link to comment
Share on other sites

3 минуты назад, Zero108 сказал:

Ну, отключи авторизацию через сервисы майкрософт и попробуй удалить всё стороннее (например, счетчики статистики и сторонние темы). Невозможно ничего сказать далее без ссылки на сам ресурс.

В этом и проблема, что форум практически полностью в стандартном виде. Установлена лишь тема, но ошибка летит даже если стоит стандартная тема. Авторизации нет, счетчиков нет

Ресурс: forum.gta5rpg.net
Но подчеркну, что проблема не массового характера, лишь у некоторых юзеров

Link to comment
Share on other sites

Значит что-то установлено, что обращается к серверу, от которого не может получить ответ. Из ничего что-то не бывает. Всегда есть причина. 

У тебя же там какое-то приложение для игры раздается. Оно какое-то имеет отношение к твоему серверу, а в частности к движку сайта? Например, для вывода статистики этого приложения на сайте или еще что-то?

Link to comment
Share on other sites

3 часа назад, tatowka сказал:

это реально как-то пофиксить? или только обновление движка?

пока особо не знаю что можно предложить, ошибка не связана с какими то настройками ips, она происходит уже из-за пользователя на стороне приложения установленного у него на экране, которое не может отправить уведомление.

1. Проверить манифест, все ли тут есть, все ли иконки и т.д. /admin/?app=core&module=customization&controller=icons
Так же снизу попробуй переключить на другой тип приложения, проверь останется ли ошибка.

2. Если ничего не помогло можно попробовать сделать так:
\system\Notification\Notification.php
заменить эту часть кода:
image.thumb.png.865c5766b911cdd23c66740aaa2dfcb3.png

на

\IPS\Task::queue( 'core', 'PWANotifications', $pwaPushNotifications, 2 );

по идеи так он не прервет ошибкой другие функции, а отправит отправку уведомления в задачи

Edited by Exception
Link to comment
Share on other sites

37 минут назад, Exception сказал:

пока особо не знаю что можно предложить, ошибка не связана с какими то настройками ips, она происходит уже из-за пользователя на стороне приложения установленного у него на экране, которое не может отправить уведомление.

1. Проверить манифест, все ли тут есть, все ли иконки и т.д. /admin/?app=core&module=customization&controller=icons
Так же снизу попробуй переключить на другой тип приложения, проверь останется ли ошибка.

2. Если ничего не помогло можно попробовать сделать так:
\system\Notification\Notification.php
заменить эту часть кода:
image.thumb.png.865c5766b911cdd23c66740aaa2dfcb3.png

на

\IPS\Task::queue( 'core', 'PWANotifications', $pwaPushNotifications, 2 );

по идеи так он не прервет ошибкой другие функции, а отправит отправку уведомления в задачи

1. Проверил, все на месте. Активировал сам манифест, проблема сохранилась. При чем в скрытом разделе если пост оставляю - все окей, нормально работает (но так и было)
2. А это спасение) Помогло. Спасибо большое!

Link to comment
Share on other sites

Вдруг кому-то будет полезно, расскажу как пофиксил без костыля выше:
admin/?app=core&module=membersettings&controller=notifications
Задал всем категориям на параметре пуш-уведомлений "отключено", после этого сбросил настройки всех пользователей до стандартных - готово.

Костыль, который предложил @Exceptionработает исправно, но вызывает блокировку задачи queue.
 

PS. Может кто-то знает, как очистить очередь этой задачи? Вручную не удается запустить из-за той же ошибки, видимо нужно подчистить текущие задачи и дальше будет нормально работать.
image.png.3735717e94bbb27921dc72f1d9fecdf6.png

Link to comment
Share on other sites

25 минут назад, tatowka сказал:

Вдруг кому-то будет полезно, расскажу как пофиксил без костыля выше:
admin/?app=core&module=membersettings&controller=notifications
Задал всем категориям на параметре пуш-уведомлений "отключено", после этого сбросил настройки всех пользователей до стандартных - готово.

Костыль, который предложил @Exceptionработает исправно, но вызывает блокировку задачи queue.
 

PS. Может кто-то знает, как очистить очередь этой задачи? Вручную не удается запустить из-за той же ошибки, видимо нужно подчистить текущие задачи и дальше будет нормально работать.
image.png.3735717e94bbb27921dc72f1d9fecdf6.png

попробуй посмотреть в таблицах бд

core_queue

и

core_notifications_pwa_queue

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...