Jump to content

Неизвестный символ в репутации и лайках


Гонза
 Share

Recommended Posts

Добрый день, тестирую форум IPS Community Suite 4.1.16.1 и при поднятие на локалке форума обнаружил следующий баг или ошибку кодировки. Если уровень репутации или количество постов перевалило за 1000, то появляется значок вопроса в ромбе. Ребят, кто знает, как его можно убрать?

 

Снимок.JPG

Link to comment
Share on other sites

Реальная цифра какая? 2086 или 2х086? Если первая, значит форум вместо неразрывного пробела ( ) отдает что-то другое. Посмотрите, что там через «Просмотреть код» в гугл хром. Также отключите расширения. Проверьте отдаваемую кодировку сервером, должна быть UTF8.

Edited by ram108
Link to comment
Share on other sites

Реальная цифра 2896 и 1457, суть в том, что приплюсовывается этот символ -?- к каждой тысяче.

В коде от Хрома тоже самое

11.JPG

Link to comment
Share on other sites

БД сконвертировал из 1251  в UTF-8, конвертация ошибок не показала. Если меня в админке значение репутации и ставлю меньше тысячи, то символа нет, если больше тысячи, то он появляется. И так у всех пользователей.

Link to comment
Share on other sites

Здесь дело не в кодировке базы данных. Проверяйтесь кодировку страницы html, которую отдает сервер. У вас видимо сервер отдает в Windows-1251, а нужно UTF8.

5 часов назад, Гонза сказал:

Если меня в админке значение репутации и ставлю меньше тысячи, то символа нет, если больше тысячи, то он появляется.

Все верно, форум пытается отформатировать число, добавляя неразрывный пробел перед третьей цифрой. Посмотрите, как это выглядит на этом форуме. Этот неразрывный пробел ваш http-сервер не может отобразить в кодировке, которую вы используете. Вот вы и получаете "неизвестный символ".

Link to comment
Share on other sites

Отбой, спасибо за помощь. Как выяснилось, Google Chrome показывает нормально цифры, ошибку выдаёт Firefox. Буду искать в ней проблему.

Link to comment
Share on other sites

  • 1 month later...

Такая же проблема и у меня. И тоже только с Лисой.

Если найдете решение, прошу отписаться. Спс

Link to comment
Share on other sites

В 14.12.2016 в 13:34, lexx74 сказал:

Такая же проблема и у меня. И тоже только с Лисой.

Если найдете решение, прошу отписаться. Спс

Здесь предложили решение-костыль, но он работает.

 

Link to comment
Share on other sites

  • 6 months later...

Прошу помощи точно такая же ошибка

как решить данную проблему не могу разобраться помоги пожалуйста.

 

Link to comment
Share on other sites

2 минуты назад, XEXXA сказал:

Прошу помощи точно такая же ошибка

Из того, что выше не помогло? 

з.ы Мы не ВАНГИ! Укажите сайт в профиле, сделайте скрин, и.т.

Link to comment
Share on other sites

4 минуты назад, XEXXA сказал:

Прошу помощи точно такая же ошибка

как решить данную проблему не могу разобраться помоги пожалуйста.

 

 

Link to comment
Share on other sites

Безымянный.png

вот скрин ребят помогите решить проблему у меня так отображает во всех броузерах а как решить не знаю

 

Link to comment
Share on other sites

1 минуту назад, Silence сказал:

А попробували ответ више ...

 

Опыта настолько большого не имею не могли бы вы помочь мне ? сам боюсь что то где то лазить трогать

Link to comment
Share on other sites

Sillenc спасибо большое братан помог как некогда спасибо всем самый классный форум у вас ребят спасибо всем.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...