Jump to content
Sign in to follow this  
FrostDelta123

Ошибка при установке.

Recommended Posts

У вас же подсказка перед глазами: controller=login&error=NO_ADSESS

Ошибку генерит этот код в system/Session/Admin.php

			if ( \IPS\Request::i()->adsess !== $session['session_id'] )
			{
				throw new \DomainException('NO_ADSESS');
			}

Вариантов несколько, либо в параметрах не передается adsess, либо сессии не пишутся в базу, либо в функцию не передается сессия. Ставим после строки  

            $session = \IPS\Db::i()->select( '*', 'core_sys_cp_sessions', array( 'session_id=?', $sessionId ) )->first();

строку
 

		var_dump($sessionId, \IPS\Request::i()->adsess, $session['session_id']); die;

и смотрим,  что глючит. При нормальной работе все три параметра должны быть одинаковы.
 

Share this post


Link to post
Share on other sites
В 05.06.2019 в 23:38, Desti сказал:

У вас же подсказка перед глазами: controller=login&error=NO_ADSESS

Ошибку генерит этот код в system/Session/Admin.php

			if ( \IPS\Request::i()->adsess !== $session['session_id'] )
			{
				throw new \DomainException('NO_ADSESS');
			}

Вариантов несколько, либо в параметрах не передается adsess, либо сессии не пишутся в базу, либо в функцию не передается сессия. Ставим после строки  

            $session = \IPS\Db::i()->select( '*', 'core_sys_cp_sessions', array( 'session_id=?', $sessionId ) )->first();

строку
 

		var_dump($sessionId, \IPS\Request::i()->adsess, $session['session_id']); die;

и смотрим,  что глючит. При нормальной работе все три параметра должны быть одинаковы.
 

Прошу прощения, что не отвечал долго. Прописал это, выдало image.png.6f95afb4bc7f8635ecd78c4a1c2eecda.png

честно говоря, вообще профан в php, не знаю, что такое. Буду благодарен за подсказку

Share this post


Link to post
Share on other sites

Есть кое какая мысль. На сайте поломалась адресация. Все ссылки открываются только если указать полный путь. То есть /forum - не работает, а /forum/index.php работает, как бы настроить нормально?

Share this post


Link to post
Share on other sites
1 час назад, FrostDelta123 сказал:

Есть кое какая мысль. На сайте поломалась адресация. Все ссылки открываются только если указать полный путь. То есть /forum - не работает, а /forum/index.php работает, как бы настроить нормально?

настройки ЧПУ(FURL) смотри, возможно они работают неправильно, там должно ошибку написать 

Share this post


Link to post
Share on other sites
11 часов назад, accop сказал:

настройки ЧПУ(FURL) смотри, возможно они работают неправильно, там должно ошибку написать 

В настройках DLE ЧПУ активно, всё есть. Ошибки даже уже не знаю, где смотреть.
image.thumb.png.ee8ba3afbc2dfdb032aa977d22f19706.png
Да и это таки не решает проблему с админкой 

Share this post


Link to post
Share on other sites
В 09.06.2019 в 16:55, FrostDelta123 сказал:

\IPS\Request::i()->adsess - NULL

Это странно. Сессия передается в функцию, совпадает с записью в базе, но не передается в строке параметров. Может у вас с настройками сервера проблемы, какие-то ограничения на длину параметров GET (хотя nginx возвращал бы 414)..

Share this post


Link to post
Share on other sites
51 минуту назад, Desti сказал:

Это странно. Сессия передается в функцию, совпадает с записью в базе, но не передается в строке параметров. Может у вас с настройками сервера проблемы, какие-то ограничения на длину параметров GET (хотя nginx возвращал бы 414)..

Переставил всё с 0, обновил PHP до 7.3. Теперь такое
image.png.77eeaf4db5a1c9f09512909ebd161161.png

Share this post


Link to post
Share on other sites

По такому описанию ошибки ничего понять не получится. Просите коммерческой помощи (не у меня).

Share this post


Link to post
Share on other sites
В 10.06.2019 в 23:11, FrostDelta123 сказал:

Переставил всё с 0, обновил PHP до 7.3. Теперь такое
image.png.77eeaf4db5a1c9f09512909ebd161161.png

А все необходимые расширения php включены?

Php info в студию 

Share this post


Link to post
Share on other sites
13 минут назад, accop сказал:

Столько всего на сервере,вроде всё на месте. даже не знаю, что могло пойти не так.

Вот и я никак не понимаю. Если интересно взглянуть своими галзами 
https://sv.ru-m.org/forumbeta/admin/index.php

Share this post


Link to post
Share on other sites
4 часа назад, 0102 сказал:

Поменяйте vds))

да толку менять, если тут надо настроить.

FrostDelta123 Давай в лс доступ к хостингу, попробую поставить сам 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×