Jump to content

Ошибка foreach() при обновлении


intercar
 Share

Recommended Posts

Вот такая вот ошибка:

Invalid argument supplied for foreach() 
/applications/core/sources/Setup/Upgrade.php::1192

Непонятно с чем связано.

А вот участок файла:

    public static function repairFileUrls( $application )
    {
        $settings = json_decode( \IPS\Settings::i()->upload_settings, TRUE );
        foreach ( $settings as $k => $v )
        {
            $exploded = explode( '_', $k );
            $classname = "IPS\\{$exploded[2]}\\extensions\\core\\FileStorage\\{$exploded[3]}";
            
            if ( $exploded[2] != $application )
            {
                continue;
            }
        
            if( class_exists( $classname ) )
            {
                $extension = new $classname;
                                                
                \IPS\Task::queue( 'core', 'RepairFileUrls', array( 'storageExtension' => $k, 'count' => $extension->count() ), 1 );
            }
        }
    }

    /**
     * Determine what our cutoff should be for long running queries
     *
     * @param    array     $changes    The changes to make to the mr data
     * @return  string
     */
    public static function adjustMultipleRedirect( $changes )
    {
        $mr = json_decode( urldecode( base64_decode( \IPS\Request::i()->mr ) ), TRUE );
        
        foreach( $changes as $k => $v )
        {
            if( is_array( $v ) )
            {
                foreach( $v as $_k => $_v )
                {
                    $mr[ $k ][ $_k ]    = $_v;
                }
            }
            else
            {
                $mr[ $k ]    = $v;
            }
        }
        
        \IPS\Request::i()->mr = base64_encode( urlencode( json_encode( $mr ) ) );

        return \IPS\Request::i()->mr;
    }
}

Link to comment
Share on other sites

  • 4 weeks later...

тоже обновляю с  3.4.6 ошибка applications/core/sources/Setup/Upgrade.php::1192

залил 4 поверх 3,4,6

        $settings = json_decode( \IPS\Settings::i()->upload_settings, TRUE );
        foreach ( $settings as $k => $v )
        {
            $exploded = explode( '_', $k );

Link to comment
Share on other sites

  • 1 month later...

на одном форуме нашел рекомендацию - перед конвертом БД отключить все моды и хаки

сделал так, кэш почистил - не помогло

Link to comment
Share on other sites

Отключать бесполезно, там ошибка при конвертации таблицы настроек, похоже. Удаляйте все нафиг, включая темы, кроме дефолтной и приложения, на котрорые нет апгрейда соответствующей версии.
 

Link to comment
Share on other sites

имеется ввиду перед обновлением в 3 й верисии выставить дефолтный шаблон? остальное убить?

щас попробую - о результатах отпишусь здесь

Link to comment
Share on other sites

       foreach( $changes as $k => $v )
        {
            if( is_array( $v ) )
            {
                foreach( $v as $_k => $_v )           может тут проблема ?
                {
                    $mr[ $k ][ $_k ]    = $_v;

а че ты паришься сохрани все данные и бд , и поставься с чистой

Link to comment
Share on other sites

Если удаление всего лишнего, перед обновлением, не помогло, значит, нужно мониторить ошибки mysql и чистить базу. Сами вряд ли справитесь.
 

Про чистый форум, это, видимо, конвертор баз IPS использовать предлагают, можете попробовать. - community.invisionpower.com/files/file/7814-ips4-converters/

C IPB он тоже работает, если не ошибаюсь.
 

Link to comment
Share on other sites

Тоже не могу обновить форум и решить эту проблему! Помогите друзья :-)

Invalid argument supplied for foreach() 
applications/core/sources/Setup/Upgrade.php::1192

 

Link to comment
Share on other sites

Только что, mistudioru сказал:

А если без шуток

Поставьте нормальную ссылку на свой форум для того, что бы можно было зайти и посмотреть, что у вас там происходит.

Link to comment
Share on other sites

нет

по совету с буржуйских форумов пробовал отключать хуки и моды , выставлял дизайн в дефолт,

ни чего не помогло

Link to comment
Share on other sites

Тоже, первый раз с такой проблемой столкнулся... Пока не могу решить.  Обновил до 3.4.9,  думал затем процесс пойдет, но тоже бесполезно....

Я так понимаю тут проблема с кодировкой БД!

Link to comment
Share on other sites

Задал вопросы на параллельных форумах, если что-то нарою напишу тут обязательно! Просто уже дело принципа :-) Убил кучу времени :-)

Может это проблема в настройках модулей php? Хотя должно до обновления ругаться!?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...