Jump to content

f2065

Новичок
  • Content Count

    9
  • Joined

  • Last visited

About f2065

  • Rank
    Новичок

Информация

  • Форум
  • Пол
    Мужчина
  • Интересы
    IT
  • Версия Invision Community
    4.4
  1. В штатном редакторе локализации можно переводить строки в том числе и от плагинов. Однако, в IPS 4.4 при выгрузке файла локализации оказывается что строки плагинов в файл не попадают. И как экспортировать переведённые строки плагинов в таком случае? Не логично получается - редактор позволяет их редактировать, но не позволяет выгружать…
  2. Т.е. делая новую версию плагина - надо не менять старую версию, а добавлять ещё одну строку новой версии? А как эта история плагина используется? Где-то есть ещё какие-то связанные с версиями куски кода или что?
  3. 1. Как делать бекап среды разработки плагина? Просто папку плагина сохранять или ещё что-то из базы? Насколько я понимаю, готовый плагин после выгрузки обратно вернуть в среду разработки нельзя. Т.е. если я в будущем захочу что-то изменить в своём плагине - то мне надо хранить исходную среду разработки… Но бекап всего форума хранить наверно излишне. 2. В Developer Center у плагина вкладка Versions (во множественном числе). И там можно создать несколько разных номеров версии. В чём смысл?! Ведь по идее версия плагина всегда какая-то одна.
  4. Вопрос в том как сделать в плагине сразу два языка (английский и русский). Я хочу в своём плагине как-то сделать сразу оба языка (т.е. вся исходная среда разработки есть). Пока не понимаю смысл dev/lang.php, если в итоге в плагине всё равно один только язык может быть.
  5. Учусь писать плагины… DEV-режим, плагин в принципе получился… Но не понятно как сделать локализацию. В справке IPS как-то не понятно описано, строки в файл dev/lang.php я прописал (и они оттуда работают), но это только один язык. А я хочу сразу как минимум два - EN и RU. В редакторе языков моих ключей что-то я не нашёл. Визуальный редактор в DEV-режиме недоступен. Как это вообще сделать?
  6. У меня на 3.4.9 мобильная версия заработала, не помню уже что сделал. Вроде, просто перекешировал всё (темы/стили, BB-коды, языки, кэш форумов, кэш хуков)… Короче сейчас мобильная тема работает, и прикрепленные сообщения в ней нормально прикреплены, сервер не падает в 500.
  7. Так в дефолтной мобильной теме, с дефолтной же поддержкой AdMob - по идее всё должно быть корректно? Причём вот смотрю загруженный HTML-файл - нету там никаких следов баннеров, ни внизу ни наверху - движок вообще почему-то не вставляет admob в мобильную тему. В обычной теме - подключены яндекс и adsense - проблем нет. Но как в IP.Board Mobile хоть что-то встроить (кроме как вручную шаблоны дописывать)?
  8. +1 Опция в админке есть, но перекопал весь инет - по запросу IPBoard AdMob только этот топик, и на оф.сайте ещё один (тоже безполезный). Но как-то ведь оно должно работать? Очевидно, реклама для стиля IP.Board Mobile должна быть. Но, Идентификатор издателя: pub-**************** прописал - толку нет, рекламы не появилось.
  9. Похожая проблема. IPB 3.4.9, хук «Pinposts v1.3.0», и тема IP.Board Mobile не работает - валиться в HTTP Error 500. Стоит ещё хук «(TB) Hide Content v3.0.7» - было подозрение на конфликт двух хуков, отключал его - не помогает. Отключение Pinposts помогает, сразу же мобильная тема нормально начинает работать. Вообще все хуки кроме Pinposts отключаю - и мобильная тема падает в Error 500… Что делать?
×