Jump to content

Вопросы по обновлению Centos 7


 Share

Recommended Posts

Пытаюсь обновить Centos 7 без обновления любых пакетов, связанных с ISP Manager Lite 5, чтобы ISP Manager Lite 5 не обновился до версии 6 (иначе слетит вечная лицензия). Ввожу в консоли:

yum upgrade --exclude=isp*

Получаю раз за разом то, что показано ниже. Такое ощущение, что нет соединения ни с какими репозитариями. Также хочу установить php 8 со всеми необходимыми библиотеками. ISP Manager Lite 5 не дает этого сделать, техподдержка отвечает, что не оказывают поддержку, нужно перейти на версию 6. Что делать в данной ситуации, какие команды вополнить, чтобы проверить связь с репозитариями, добавить другие репозитарии? В принципе, достаточно было бы добавить в систему стабильную версию php 8, остальное не критично.

Last login: Sun Oct 23 15:56:00 2022 from 192.168.1.49
[[email protected] ~]# yum upgrade --exclude=isp*
Загружены модули: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.docker.ru
 * epel: ru.download.ispsystem.com
 * extras: mirror.corbina.net
 * ispsystem-5.283: ru.download.ispsystem.com
 * ispsystem-base: ru.download.ispsystem.com
 * remi: mirror.docker.ru
 * remi-safe: mirror.docker.ru
 * updates: mirror.corbina.net
base                                                     | 3.6 kB     00:00     https://artifacts.elastic.co/packages/7.x/yum/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Пробуем другое зеркало.
To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

epel                                                     | 3.0 kB     00:00     extras                                                   | 2.9 kB     00:00     ispsystem-5.283                                          | 2.9 kB     00:00     ispsystem-base                                           | 3.0 kB     00:00     mysql57-community                                        | 2.6 kB     00:00     remi                                                     | 3.0 kB     00:00     remi-safe                                                | 3.0 kB     00:00     updates                                                  | 2.9 kB     00:00     https://artifacts.elastic.co/packages/7.x/yum/repodata/primary.xml.gz: [Errno 14] HTTPS Error 403 - Forbidden
Пробуем другое зеркало.


 One of the configured repositories failed (Elasticsearch repository for 7.x packages),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.
     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=elasticsearch-6.x ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable elasticsearch-6.x
        or
            subscription-manager repos --disable=elasticsearch-6.x

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=elasticsearch-6.x.skip_if_unavailable=true

failure: repodata/primary.xml.gz from elasticsearch-6.x: [Errno 256] No more mirrors to try.
https://artifacts.elastic.co/packages/7.x/yum/repodata/primary.xml.gz: [Errno 14] HTTPS Error 403 - Forbidden
[[email protected] ~]#

 

Link to comment
Share on other sites

Эластик тоже исключайте, придурки-разработчики играют в  "Elastic підтримує Україну".

Можно настроить proxy для yum, но я с ним не работал, не знаю. 

Ну или качайте сам эластик пакетом через прокси и ручками ставьте. 

Link to comment
Share on other sites

Desti не могу понять, почему yum не выдает пакеты, которые можно обновить в примере выше. Вообще связи нет с репозитарием или я что-то не так делаю. Как проверить?

Эластик пока обновлять не планирую, так как пока все работает.

Пробую команду yum upgrade --exclude=isp* --exclude=elastic* 

Результат такой же, как в примере выше.

ISP Manager тоже не дает обновить PHP через свою панельку, так как поддержка ISP Lite 5 закончилась в прошлом году. Всех принуждают переходить на версию 6. Но при чем тут консоль?!  Всё это очень странно. Неужели отрезали РФ от серверов обновления?

Edited by Zero108
Link to comment
Share on other sites

Elastic отрезал Россию от обновлений, про ISP не знаю, не использую. Ошибка у вас в первом сообщении связана с недоступностью серверов elastic.

20 минут назад, Zero108 сказал:

так как поддержка ISP Lite 5 закончилась

после окончания поддержки обновления невозможны.

У вас прямо на экране подсказка: 

Run the command with the repository temporarily disabled
            yum --disablerepo=elasticsearch-6.x ...

И еще куча вариантов ниже.

Link to comment
Share on other sites

Desti Помогло выполнение команды 

yum --disablerepo=elasticsearch-6.x

Не думал, что недоступность одного из репозитариев отсанавливает все обновление. Как-то странно сделано.

Link to comment
Share on other sites

Desti Команда yum update --exclude=isp* дала следующий результат. Не могу понять, что это значит. Обновление не смогло произойти из-за какой-то ошибки опять?
 

---> Пакет cyrus-sasl-lib.x86_64 0:2.1.26-24.el7_9 помечен как обновление
---> Пакет epel-release.noarch 0:7-13 помечен для обновления
---> Пакет epel-release.noarch 0:7-14 помечен как обновление
---> Пакет exim.x86_64 0:4.94.2-1.el7 помечен для обновления
---> Пакет exim.x86_64 0:4.96-2.el7 помечен как обновление
---> Пакет expat.x86_64 0:2.1.0-12.el7 помечен для обновления
---> Пакет expat.x86_64 0:2.1.0-15.el7_9 помечен как обновление
---> Пакет fail2ban-server.noarch 0:0.11.1-10.el7 помечен для обновления
---> Пакет fail2ban-server.noarch 0:0.11.2-3.el7 помечен как обновление
---> Пакет freetds.x86_64 0:1.1.20-1.el7 помечен для обновления
---> Пакет freetds.x86_64 0:1.3.3-1.el7 помечен как обновление
---> Пакет freetds-libs.x86_64 0:1.1.20-1.el7 помечен для обновления
---> Пакет freetds-libs.x86_64 0:1.3.3-1.el7 помечен как обновление
---> Пакет glibc.x86_64 0:2.17-324.el7_9 помечен для обновления
---> Пакет glibc.x86_64 0:2.17-326.el7_9 помечен как обновление
---> Пакет glibc-common.x86_64 0:2.17-324.el7_9 помечен для обновления
---> Пакет glibc-common.x86_64 0:2.17-326.el7_9 помечен как обновление
---> Пакет glibc-devel.x86_64 0:2.17-324.el7_9 помечен для обновления
---> Пакет glibc-devel.x86_64 0:2.17-326.el7_9 помечен как обновление
---> Пакет glibc-headers.x86_64 0:2.17-324.el7_9 помечен для обновления
---> Пакет glibc-headers.x86_64 0:2.17-326.el7_9 помечен как обновление
---> Пакет grub2.x86_64 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2.x86_64 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет grub2-common.noarch 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2-common.noarch 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет grub2-efi-x64.x86_64 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2-efi-x64.x86_64 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет grub2-pc.x86_64 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2-pc.x86_64 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет grub2-pc-modules.noarch 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2-pc-modules.noarch 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет grub2-tools.x86_64 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2-tools.x86_64 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет grub2-tools-extra.x86_64 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2-tools-extra.x86_64 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет grub2-tools-minimal.x86_64 1:2.02-0.87.el7.centos.6 помечен для обновления
---> Пакет grub2-tools-minimal.x86_64 1:2.02-0.87.0.1.el7.centos.9 помечен как обновление
---> Пакет gtk-update-icon-cache.x86_64 0:3.22.30-6.el7 помечен для обновления
---> Пакет gtk-update-icon-cache.x86_64 0:3.22.30-8.el7_9 помечен как обновление---> Пакет gzip.x86_64 0:1.5-10.el7 помечен для обновления
---> Пакет gzip.x86_64 0:1.5-11.el7_9 помечен как обновление
---> Пакет httpd.x86_64 0:2.4.6-97.el7.centos помечен для обновления
---> Пакет httpd.x86_64 0:2.4.6-97.el7.centos.5 помечен как обновление
---> Пакет httpd-tools.x86_64 0:2.4.6-97.el7.centos помечен для обновления
---> Пакет httpd-tools.x86_64 0:2.4.6-97.el7.centos.5 помечен как обновление
---> Пакет java-1.8.0-openjdk.x86_64 1:1.8.0.312.b07-1.el7_9 помечен для обновления
---> Пакет java-1.8.0-openjdk.x86_64 1:1.8.0.345.b01-1.el7_9 помечен как обновление
---> Пакет java-1.8.0-openjdk-devel.x86_64 1:1.8.0.312.b07-1.el7_9 помечен для обновления
---> Пакет java-1.8.0-openjdk-devel.x86_64 1:1.8.0.345.b01-1.el7_9 помечен как обновление
---> Пакет java-1.8.0-openjdk-headless.x86_64 1:1.8.0.312.b07-1.el7_9 помечен для обновления
---> Пакет java-1.8.0-openjdk-headless.x86_64 1:1.8.0.345.b01-1.el7_9 помечен как обновление
---> Пакет kbd.x86_64 0:1.15.5-15.el7 помечен для обновления
---> Пакет kbd.x86_64 0:1.15.5-16.el7_9 помечен как обновление
---> Пакет kbd-legacy.noarch 0:1.15.5-15.el7 помечен для обновления
---> Пакет kbd-legacy.noarch 0:1.15.5-16.el7_9 помечен как обновление
---> Пакет kbd-misc.noarch 0:1.15.5-15.el7 помечен для обновления
---> Пакет kbd-misc.noarch 0:1.15.5-16.el7_9 помечен как обновление
---> Пакет kernel.x86_64 0:3.10.0-1160.76.1.el7 помечен для установки
---> Пакет kernel-devel.x86_64 0:3.10.0-1160.76.1.el7 помечен для установки
---> Пакет kernel-headers.x86_64 0:3.10.0-1160.42.2.el7 помечен для обновления
---> Пакет kernel-headers.x86_64 0:3.10.0-1160.76.1.el7 помечен как обновление
---> Пакет kernel-tools.x86_64 0:3.10.0-1160.42.2.el7 помечен для обновления
---> Пакет kernel-tools.x86_64 0:3.10.0-1160.76.1.el7 помечен как обновление
---> Пакет kernel-tools-libs.x86_64 0:3.10.0-1160.42.2.el7 помечен для обновления
---> Пакет kernel-tools-libs.x86_64 0:3.10.0-1160.76.1.el7 помечен как обновление
---> Пакет krb5-libs.x86_64 0:1.15.1-50.el7 помечен для обновления
---> Пакет krb5-libs.x86_64 0:1.15.1-54.el7_9 помечен как обновление
---> Пакет libspf2.x86_64 0:1.2.10-5.20150405gitd57d79fd.el7 помечен для обновления
---> Пакет libspf2.x86_64 0:1.2.11-1.20210922git4915c308.el7 помечен как обновление
---> Пакет libxml2.x86_64 0:2.9.1-6.el7.5 помечен для обновления
---> Пакет libxml2.x86_64 0:2.9.1-6.el7_9.6 помечен как обновление
---> Пакет libxml2-python.x86_64 0:2.9.1-6.el7.5 помечен для обновления
---> Пакет libxml2-python.x86_64 0:2.9.1-6.el7_9.6 помечен как обновление
---> Пакет libzip5.x86_64 0:1.6.1-1.el7 помечен для обновления
---> Пакет libzip5.x86_64 0:1.9.2-3.el7.remi помечен как обновление
--> Обработка зависимостей: libzstd(x86-64) >= 1.3.6 пакета: libzip5-1.9.2-3.el7.remi.x86_64
--> Обработка зависимостей: libzstd.so.1()(64bit) пакета: libzip5-1.9.2-3.el7.remi.x86_64
---> Пакет mdadm.x86_64 0:4.1-7.el7_9 помечен для обновления
---> Пакет mdadm.x86_64 0:4.1-9.el7_9 помечен как обновление
---> Пакет memcached.x86_64 0:1.4.15-10.el7_3.1 помечен для обновления
---> Пакет memcached.x86_64 0:1.6.16-1.el7.remi помечен как обновление
---> Пакет microcode_ctl.x86_64 2:2.1-73.11.el7_9 помечен для обновления
---> Пакет microcode_ctl.x86_64 2:2.1-73.14.el7_9 помечен как обновление
---> Пакет mod_authnz_external.x86_64 0:3.3.1-7.el7 помечен для обновления
---> Пакет mod_authnz_external.x86_64 0:3.3.3-3.el7 помечен как обновление
---> Пакет mod_ssl.x86_64 1:2.4.6-97.el7.centos помечен для обновления
---> Пакет mod_ssl.x86_64 1:2.4.6-97.el7.centos.5 помечен как обновление
---> Пакет mysql-community-client.x86_64 0:5.7.35-1.el7 помечен для обновления
---> Пакет mysql-community-client.x86_64 0:5.7.40-1.el7 помечен как обновление
---> Пакет mysql-community-common.x86_64 0:5.7.35-1.el7 помечен для обновления
---> Пакет mysql-community-common.x86_64 0:5.7.40-1.el7 помечен как обновление
---> Пакет mysql-community-libs.x86_64 0:5.7.35-1.el7 помечен для обновления
---> Пакет mysql-community-libs.x86_64 0:5.7.40-1.el7 помечен как обновление
---> Пакет mysql-community-libs-compat.x86_64 0:5.7.35-1.el7 помечен для обновления
---> Пакет mysql-community-libs-compat.x86_64 0:5.7.40-1.el7 помечен как обновление
---> Пакет mysql-community-server.x86_64 0:5.7.35-1.el7 помечен для обновления
---> Пакет mysql-community-server.x86_64 0:5.7.40-1.el7 помечен как обновление
---> Пакет mysqltuner.noarch 0:1.7.21-1.git.4e0a8b3.el7 помечен для обновления
---> Пакет mysqltuner.noarch 0:1.8.3-1.git.1333ea9.el7 помечен как обновление
---> Пакет net-snmp-libs.x86_64 1:5.7.2-49.el7_9.1 помечен для обновления
---> Пакет net-snmp-libs.x86_64 1:5.7.2-49.el7_9.2 помечен как обновление
---> Пакет nginx.x86_64 2:1.20.1-1.el7.ngx помечен для обновления
---> Пакет nginx.x86_64 2:1.20.2-1.el7.ngx помечен как обновление
---> Пакет nspr.x86_64 0:4.25.0-2.el7_9 помечен для обновления
---> Пакет nspr.x86_64 0:4.34.0-3.1.el7_9 помечен как обновление
---> Пакет nss.x86_64 0:3.53.1-7.el7_9 помечен для обновления
---> Пакет nss.x86_64 0:3.79.0-4.el7_9 помечен как обновление
---> Пакет nss-softokn.x86_64 0:3.53.1-6.el7_9 помечен для обновления
---> Пакет nss-softokn.x86_64 0:3.79.0-4.el7_9 помечен как обновление
---> Пакет nss-softokn-freebl.x86_64 0:3.53.1-6.el7_9 помечен для обновления
---> Пакет nss-softokn-freebl.x86_64 0:3.79.0-4.el7_9 помечен как обновление
---> Пакет nss-sysinit.x86_64 0:3.53.1-7.el7_9 помечен для обновления
---> Пакет nss-sysinit.x86_64 0:3.79.0-4.el7_9 помечен как обновление
---> Пакет nss-tools.x86_64 0:3.53.1-7.el7_9 помечен для обновления
---> Пакет nss-tools.x86_64 0:3.79.0-4.el7_9 помечен как обновление
---> Пакет nss-util.x86_64 0:3.53.1-1.el7_9 помечен для обновления
---> Пакет nss-util.x86_64 0:3.79.0-1.el7_9 помечен как обновление
---> Пакет oniguruma.x86_64 0:6.8.2-1.el7 помечен для обновления
---> Пакет oniguruma.x86_64 0:6.8.2-2.el7 помечен как обновление
---> Пакет openldap.x86_64 0:2.4.44-24.el7_9 помечен для обновления
---> Пакет openldap.x86_64 0:2.4.44-25.el7_9 помечен как обновление
---> Пакет openssh.x86_64 0:7.4p1-21.el7 помечен для обновления
---> Пакет openssh.x86_64 0:7.4p1-22.el7_9 помечен как обновление
---> Пакет openssh-clients.x86_64 0:7.4p1-21.el7 помечен для обновления
---> Пакет openssh-clients.x86_64 0:7.4p1-22.el7_9 помечен как обновление
---> Пакет openssh-server.x86_64 0:7.4p1-21.el7 помечен для обновления
---> Пакет openssh-server.x86_64 0:7.4p1-22.el7_9 помечен как обновление
---> Пакет openssl.x86_64 1:1.0.2k-21.el7_9 помечен для обновления
---> Пакет openssl.x86_64 1:1.0.2k-25.el7_9 помечен как обновление
---> Пакет openssl-libs.x86_64 1:1.0.2k-21.el7_9 помечен для обновления
---> Пакет openssl-libs.x86_64 1:1.0.2k-25.el7_9 помечен как обновление
---> Пакет php.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-bcmath.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-bcmath.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-cli.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-cli.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-common.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-common.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-fedora-autoloader.noarch 0:1.0.1-2.el7 помечен для обновления
---> Пакет php-fedora-autoloader.noarch 0:1.0.1-2.el7.remi помечен как обновление
---> Пакет php-gd.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-gd.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-intl.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-intl.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-kolab-net-ldap3.noarch 0:1.0.7-2.el7 помечен для обновления
---> Пакет php-kolab-net-ldap3.noarch 0:1.1.4-1.el7.remi помечен как обновление
---> Пакет php-ldap.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-ldap.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-mbstring.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-mbstring.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-mysql.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-mysql.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-odbc.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-odbc.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-pdo.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-pdo.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-pear.noarch 1:1.9.4-22.el7 помечен для обновления
---> Пакет php-pear.noarch 1:1.10.13-1.el7.remi помечен как обновление
---> Пакет php-pear-Auth-SASL.noarch 0:1.0.6-5.el7 помечен для обновления
---> Пакет php-pear-Auth-SASL.noarch 0:1.1.0-1.el7.remi помечен как обновление  ---> Пакет php-pear-Mail-Mime.noarch 0:1.10.2-1.el7 помечен для обновления
---> Пакет php-pear-Mail-Mime.noarch 0:1.10.11-1.el7.remi помечен как обновление---> Пакет php-pear-Net-IDNA2.noarch 0:0.1.1-10.el7 помечен для обновления
---> Пакет php-pear-Net-IDNA2.noarch 0:0.2.0-11.el7.remi помечен как обновление
---> Пакет php-pear-Net-LDAP2.noarch 0:2.1.0-1.el7 помечен для обновления
---> Пакет php-pear-Net-LDAP2.noarch 0:2.2.0-1.el7.remi помечен как обновление
---> Пакет php-pear-Net-SMTP.noarch 0:1.7.3-1.el7 помечен для обновления
---> Пакет php-pear-Net-SMTP.noarch 0:1.10.1-1.el7.remi помечен как обновление
---> Пакет php-pear-Net-Sieve.noarch 0:1.3.4-4.el7 помечен для обновления
---> Пакет php-pear-Net-Sieve.noarch 0:1.4.5-1.el7.remi помечен как обновление
---> Пакет php-pear-Net-Socket.noarch 0:1.0.14-1.el7 помечен для обновления
---> Пакет php-pear-Net-Socket.noarch 0:1.2.2-1.el7.remi помечен как обновление
---> Пакет php-pecl-igbinary.x86_64 0:1.2.1-1.el7 помечен для обновления
---> Пакет php-pecl-igbinary.x86_64 0:2.0.8-1.el7.remi.5.4 помечен как обновление
---> Пакет php-pecl-redis.x86_64 0:2.2.8-1.el7 помечен для обновления
---> Пакет php-pecl-redis.x86_64 0:3.1.6-1.el7.remi.5.4 помечен как обновление
---> Пакет php-php-gettext.noarch 0:1.0.12-1.el7 помечен для обновления
---> Пакет php-php-gettext.noarch 0:1.0.12-1.el7.remi помечен как обновление
---> Пакет php-process.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-process.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-pspell.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-pspell.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-tcpdf.noarch 0:6.2.26-1.el7 помечен для обновления
---> Пакет php-tcpdf.noarch 0:6.5.0-1.el7.remi помечен как обновление
---> Пакет php-tcpdf-dejavu-sans-fonts.noarch 0:6.2.26-1.el7 помечен для обновления
---> Пакет php-tcpdf-dejavu-sans-fonts.noarch 0:6.5.0-1.el7.remi помечен как обновление
---> Пакет php-tidy.x86_64 0:5.4.16-9.el7 помечен для обновления
---> Пакет php-tidy.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет php-xml.x86_64 0:5.4.16-48.el7 помечен для обновления
---> Пакет php-xml.x86_64 0:5.4.45-19.el7.remi помечен как обновление
---> Пакет phpMyAdmin.noarch 0:4.4.15.10-6.el7 помечен для обновления
---> Пакет phpMyAdmin.noarch 0:5.2.0-1.el7.remi помечен как обновление
--> Обработка зависимостей: php(language) >= 7.2.5 пакета: phpMyAdmin-5.2.0-1.el7.remi.noarch
---> Пакет polkit.x86_64 0:0.112-26.el7 помечен для обновления
---> Пакет polkit.x86_64 0:0.112-26.el7_9.1 помечен как обновление
---> Пакет postgresql-libs.x86_64 0:9.2.24-7.el7_9 помечен для обновления
---> Пакет postgresql-libs.x86_64 0:9.2.24-8.el7_9 помечен как обновление
---> Пакет proftpd.x86_64 0:1.3.5e-10.el7 помечен для обновления
---> Пакет proftpd.x86_64 0:1.3.5e-12.el7 помечен как обновление
---> Пакет python.x86_64 0:2.7.5-90.el7 помечен для обновления
---> Пакет python.x86_64 0:2.7.5-92.el7_9 помечен как обновление
---> Пакет python-libs.x86_64 0:2.7.5-90.el7 помечен для обновления
---> Пакет python-libs.x86_64 0:2.7.5-92.el7_9 помечен как обновление
---> Пакет python-perf.x86_64 0:3.10.0-1160.42.2.el7 помечен для обновления
---> Пакет python-perf.x86_64 0:3.10.0-1160.76.1.el7 помечен как обновление
---> Пакет redis.x86_64 0:6.2.5-1.el7.remi помечен для обновления
---> Пакет redis.x86_64 0:7.0.5-2.el7.remi помечен как обновление
---> Пакет remi-release.noarch 0:7.9-2.el7.remi помечен для обновления
---> Пакет remi-release.noarch 0:7.9-4.el7.remi помечен как обновление
---> Пакет roundcubemail.noarch 0:1.4.11-3.el7 помечен для обновления
---> Пакет roundcubemail.noarch 0:1.6.0-1.el7.remi помечен как обновление
--> Обработка зависимостей: php(language) >= 7.3 пакета: roundcubemail-1.6.0-1.el7.remi.noarch
---> Пакет rpm.x86_64 0:4.11.3-45.el7 помечен для обновления
---> Пакет rpm.x86_64 0:4.11.3-48.el7_9 помечен как обновление
---> Пакет rpm-build-libs.x86_64 0:4.11.3-45.el7 помечен для обновления
---> Пакет rpm-build-libs.x86_64 0:4.11.3-48.el7_9 помечен как обновление
---> Пакет rpm-libs.x86_64 0:4.11.3-45.el7 помечен для обновления               ---> Пакет rpm-libs.x86_64 0:4.11.3-48.el7_9 помечен как обновление
---> Пакет rpm-python.x86_64 0:4.11.3-45.el7 помечен для обновления
---> Пакет rpm-python.x86_64 0:4.11.3-48.el7_9 помечен как обновление
---> Пакет rsync.x86_64 0:3.1.2-10.el7 помечен для обновления
---> Пакет rsync.x86_64 0:3.1.2-11.el7_9 помечен как обновление
---> Пакет rsyslog.x86_64 0:8.24.0-57.el7_9.1 помечен для обновления
---> Пакет rsyslog.x86_64 0:8.24.0-57.el7_9.3 помечен как обновление
---> Пакет sudo.x86_64 0:1.8.23-10.el7_9.1 помечен для обновления
---> Пакет sudo.x86_64 0:1.8.23-10.el7_9.2 помечен как обновление
---> Пакет systemd.x86_64 0:219-78.el7_9.3 помечен для обновления
---> Пакет systemd.x86_64 0:219-78.el7_9.7 помечен как обновление               ---> Пакет systemd-libs.x86_64 0:219-78.el7_9.3 помечен для обновления          ---> Пакет systemd-libs.x86_64 0:219-78.el7_9.7 помечен как обновление          ---> Пакет systemd-python.x86_64 0:219-78.el7_9.3 помечен для обновления        ---> Пакет systemd-python.x86_64 0:219-78.el7_9.7 помечен как обновление        ---> Пакет systemd-sysv.x86_64 0:219-78.el7_9.3 помечен для обновления          ---> Пакет systemd-sysv.x86_64 0:219-78.el7_9.7 помечен как обновление          ---> Пакет tuned.noarch 0:2.11.0-11.el7_9 помечен для обновления                ---> Пакет tuned.noarch 0:2.11.0-12.el7_9 помечен как обновление                ---> Пакет tzdata.noarch 0:2021a-1.el7 помечен для обновления                   ---> Пакет tzdata.noarch 0:2022d-1.el7 помечен как обновление                   ---> Пакет tzdata-java.noarch 0:2021e-1.el7 помечен для обновления              ---> Пакет tzdata-java.noarch 0:2022d-1.el7 помечен как обновление              ---> Пакет unzip.x86_64 0:6.0-22.el7_9 помечен для обновления                   ---> Пакет unzip.x86_64 0:6.0-24.el7_9 помечен как обновление                   ---> Пакет xz.x86_64 0:5.2.2-1.el7 помечен для обновления                       ---> Пакет xz.x86_64 0:5.2.2-2.el7_9 помечен как обновление                     ---> Пакет xz-libs.x86_64 0:5.2.2-1.el7 помечен для обновления                  ---> Пакет xz-libs.x86_64 0:5.2.2-2.el7_9 помечен как обновление                ---> Пакет zlib.x86_64 0:1.2.7-19.el7_9 помечен для обновления
---> Пакет zlib.x86_64 0:1.2.7-20.el7_9 помечен как обновление                  --> Проверка сценария                                                           ---> Пакет libzstd.x86_64 0:1.5.2-1.el7 помечен для установки                   ---> Пакет phpMyAdmin.noarch 0:5.2.0-1.el7.remi помечен как обновление
--> Обработка зависимостей: php(language) >= 7.2.5 пакета: phpMyAdmin-5.2.0-1.el7.remi.noarch
---> Пакет roundcubemail.noarch 0:1.6.0-1.el7.remi помечен как обновление
--> Обработка зависимостей: php(language) >= 7.3 пакета: roundcubemail-1.6.0-1.el7.remi.noarch
--> Проверка зависимостей окончена
--> Проверка сценария
---> Пакет kernel.x86_64 0:3.10.0-1160.25.1.el7 помечен для удаления
---> Пакет phpMyAdmin.noarch 0:5.2.0-1.el7.remi помечен как обновление
--> Обработка зависимостей: php(language) >= 7.2.5 пакета: phpMyAdmin-5.2.0-1.el7.remi.noarch
---> Пакет roundcubemail.noarch 0:1.6.0-1.el7.remi помечен как обновление       --> Обработка зависимостей: php(language) >= 7.3 пакета: roundcubemail-1.6.0-1.el7.remi.noarch                                                                  --> Проверка зависимостей окончена
Ошибка: Пакет: roundcubemail-1.6.0-1.el7.remi.noarch (remi)
            Необходимо: php(language) >= 7.3
            Удаление: php-common-5.4.16-48.el7.x86_64 (@base)
                php(language) = 5.4.16                                                      Обновил: php-common-5.4.45-19.el7.remi.x86_64 (remi)
                php(language) = 5.4.45
            Доступно: php-common-5.4.45-18.el7.remi.x86_64 (remi)
                php(language) = 5.4.45
Ошибка: Пакет: phpMyAdmin-5.2.0-1.el7.remi.noarch (remi)
            Необходимо: php(language) >= 7.2.5
            Удаление: php-common-5.4.16-48.el7.x86_64 (@base)
                php(language) = 5.4.16
            Обновил: php-common-5.4.45-19.el7.remi.x86_64 (remi)
                php(language) = 5.4.45
            Доступно: php-common-5.4.45-18.el7.remi.x86_64 (remi)
                php(language) = 5.4.45
 Вы можете попробовать --skip-broken чтобы обойти проблему
 Вы можете попробовать запустить: rpm -Va --nofiles --nodigest
[[email protected] ~]#  

 

Link to comment
Share on other sites

Все результаты выполнения в консоли увидеть не удается, их очень много. Как вывести на экран по частям не нашел. 

Ну, и остается вопрос, как всё-таки поставить php 8 без панельки ISP Lite через консоль. Нагуглил вот такую команду https://aeb-blog.ru/linux/ustanovka-i-obnovlenie-do-php-8-v-centos-7/  Не совсем понятно, эта команда перезатрет или не перезатрет старые версии пхп в Centos 7. Мне нужно добавить версию php 8, не перезатирая другие версии php, установленные на сервере.

yum install php80 php-fpm php-cli php-mysql php-gd php-ldap php-odbc php-pdo php-pecl-memcache php-opcache php-pear php-xml php-xmlrpc php-mbstring php-snmp php-soap php-zip php-imagick

Какая сейчас стабильная версия php 8?

 

Edited by Zero108
Link to comment
Share on other sites

php не перекрывают друг-друга, у меня одновременно стоит 7.3, 7.4, 8.0 и 8.1 - запущены обычно две, но можно запустить все. 

текущая stable - 8.1.11, но в репозиториях обычно версия постарше, совсем свежие ставят из сторонних (PPA) репозиториев. 

Link to comment
Share on other sites

 

Desti при создании тестового домена в панели ISP Lite, панелька назначила ему php 7, который видит. В каком месте переопределить на php 8.1 на сервере? Apache + Nginx

Edited by Zero108
Link to comment
Share on other sites

Я не имею ни малейшего представления, что наворотил ISP в системе и как он вообще работает. Костылями не пользуюсь, ищите тех, кто знает.

Apache последний раз настраивал лет 10 назад.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...