Jump to content

Какой релиз лучше выбрать 3 или 4?


vovchik3003
 Share

Recommended Posts

Привет форумчани. Наверное уже надоевший вам вопрос, но все-таки спрошу. Для нового форума, что лучше сейчас выбрать 3 или 4?(релизы с этого форума) И почему?

 

Простите за банальный вопрос.

Link to comment
Share on other sites

Для нового форума лучше выбирать 4.х так как он более перспективный. Версию 3.х для новых форумов лучше не использовать

Edited by Sanshalay
Link to comment
Share on other sites

Для нового форума лучше выбирать 4.х так как он более перспективный. Версию 3.х для новых форумов лучше не использовать

А почему не использовать? Тут на форуме для 4 версии модов меньше, чем для 3. И я правильно понял, что еще русифицированной стабильной нуленой версии нет?

Link to comment
Share on other sites

А почему не использовать? Тут на форуме для 4 версии модов меньше, чем для 3. И я правильно понял, что еще русифицированной стабильной нуленой версии нет?

всё есть.

Link to comment
Share on other sites

всё есть.

Можете скинуть ссылочку, пожалуйста, на самую актуальную версию на данный момент (на данном форуме). 

И еще интересует: моды для 3 версии подходят для 4?

Простите за глупые вопросы :)

Link to comment
Share on other sites

Можете скинуть ссылочку, пожалуйста, на самую актуальную версию на данный момент (на данном форуме). 

И еще интересует: моды для 3 версии подходят для 4?

Простите за глупые вопросы :)

http://ipbmafia.ru/files/file/1490-ips-community-suite-4-nulled/

Самая актуальная для новых форумов 

Link to comment
Share on other sites

http://ipbmafia.ru/files/file/1490-ips-community-suite-4-nulled/

Самая актуальная для новых форумов 

Спасибо)))) а моды от 3 версии подойдут или не все?

Link to comment
Share on other sites

Спасибо)))) а моды от 3 версии подойдут или не все?

Нет конечно же. Я даже больше скажу, не все из существующих плагинов для ветки 4.0 будут работать в будущей 4.1, что уж говорить о совместимости между 3 и 4 веткой

Link to comment
Share on other sites

Нет конечно же. Я даже больше скажу, не все из существующих плагинов для ветки 4.0 будут работать в будущей 4.1, что уж говорить о совместимости между 3 и 4 веткой

Тогда какой резон ставить 4 версию, если плагинов практически нет для нее на форуме?

Link to comment
Share on other sites

Тогда какой резон ставить 4 версию, если плагинов практически нет для нее на форуме?

Вам же уже ответили, по причине большей перспективности этой ветки.

Во-первых в 4-й ветке изначально масса того функционала, который в 3-ке достигался при помощи хуков и т.д. уже есть так сказать "из коробки".

Во-вторых, архитектура 4-й ветки несравнимо лучше в плане дальнейшей модификации имеющегося функционала (будь то те-же стили или плагины).

В-третьих, количество плагинов для 4 ветки, всего лишь вопрос времени, когда-то для тройки их тоже было не так уж много.

В-четвертых, никто ни за что не агитирует, каждый выбирает для себя то что ему ближе, удобней и т.д.

Link to comment
Share on other sites

Спасибо за развернутый ответ) Просто раньше не работал с системой и решил проконсультироваться у знающих людей)

Link to comment
Share on other sites

@vovchik3003 просто ключевое слово в вашем вопросе - "для нового форума", потому ответ @Sanshalay в пользу 4-й ветки, вполне справедлив. 

Другое дело если речь идет обо обновлении существующего форума, тогда конечно есть ньюансы с потерей некоторого "привычного" функционала, обеспечиваемого сторонними хуками или приложениями, которые пока еще не портированы на 4-ую ветку. Ну либо же у вас в ТЗ к новому форуму, есть какие либо специфические требования, которые опять таки ПОКА ЕЩЕ не реализованы (или просто недоступны в паблике) для 4-ки.

Link to comment
Share on other sites

@vovchik3003, ветка 3-йки закончилась на 3.4.8, она дальше не развивается. Рано или поздно столкнешься с необходимостью обновить версию форума, если будешь постоянно держать его в актуальном состоянии. Например, для 4-ки выйдут актуальные дополнения, которые ты захочешь поставить, но у тебя версия форума не та... Сейчас многие дополнения которые есть на 3, переделывают под 4.

имхо: лучше 4-ку брать

Link to comment
Share on other sites

Спасибо за развернутый ответ) Просто раньше не работал с системой и решил проконсультироваться у знающих людей)

Полно различных плагинов

 

Я тоже за 4. Мне она больше нравится. Адаптивный дизайн, удобный поиск - всё это не может не радовать)

Link to comment
Share on other sites

Я работал довольно много на версии 3.хх, сейчас думаю вернутся в эту сферу, и прочитав, посмотрев все данные о 4, смело скажу что 4 в разы лучше 3.

 

Link to comment
Share on other sites

4.1 (хоть пока и бета), ИМХО еще "нарядней". Чего только стоят улучшенные Activities и долгожданная возможность цитирования выделенного))

Link to comment
Share on other sites

не все из существующих плагинов для ветки 4.0 будут работать в будущей 4.1

Это ОЧЕНЬ небольшое количество плагинов. В основном всё будет работать. Разве что необходимость в некоторых плагинах отпадёт (например мой Current Version Info теперь не нужен т.к. его функционал был внедрён в версию 4.1 по умолчанию)

Link to comment
Share on other sites

@Sanshalay это понятно, там даже те что "не будут работать", допиливаются в элементе, разница буквально в чуть измененной структуре некоторых классов и т.д., я просто хотел подчеркнуть, что если даже между 4.0 и 4.1 бывают изменения приводящие к неработоспособности плагинов, то что уж там говорить о преемственности 3 > 4, где архитектура отличается в корне.

Link to comment
Share on other sites

Тройка конечно же - шаблонов куча и хуков тоже, более быстрая и менее требовательная к ресурсам сервера.

Когда будет для четвёрки всё необходимое, тогда можно и обновится.

Я вообще долго сидел на 2.3.6 потом обновил сразу все форумы до 3.4.6

Edited by bsnet
Link to comment
Share on other sites

Тройка конечно же - шаблонов куча и хуков тоже, более быстрая и менее требовательная к ресурсам сервера.

Когда будет для четвёрки всё необходимое, тогда можно и обновится.

Я вообще долго сидел на 2.3.6 потом обновил сразу все форумы до 3.4.6

Для 4.0 есть всё необходимое. Шах и мат

Link to comment
Share on other sites

Спасибо за ответы)))

А все моды платные или есть бесплатные и где посмотреть?) (кроме как тут)

Link to comment
Share on other sites

Спасибо за ответы)))

А все моды платные или есть бесплатные и где посмотреть?) (кроме как тут)

Хватает и бесплатных. Есть они в файловом архиве IPS, но нужно быть ихним клиентом что бы качать бесплатные моды. Кроме мафии есть и другие аналогичные ресурсы, где можно найти моды и т.п. Особенно зарубежные.

Link to comment
Share on other sites

  • 3 months later...

выбирай то, что поддерживается и развивается, чтобы в будущем можно было проще обновиться. на данный момент это 4ка.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...