Jump to content
Respected

Invision Community Nulled

Recommended Posts

Обновился. Появились сильные тормоза, google page speed снизил оценку с 82 до 72. При открытии статьи в pages ошибка скрипта. И это со стандартным шаблоном. В общем откатился назад. Сушить ее и сушить еще )

С изображениями проблем небыло. Перестроились без проблем. Лишние удалились, освободив три гб на диске.

Share this post


Link to post
Share on other sites

мои 5 копеек.

Обновление не пошло 500 ошибка, в логи ничего не хочет записываться.

новая установка тоже с 500 ошибкой, в логах пишет вот это:

Цитата

2019/02/26 09:56:16 [error] 12424#12424: *10513595 FastCGI sent in stderr: "PHP message: PHP Fatal error:  require(): Failed opening required '/home/***/www/***.com/conf_global.php' (include_path='.:/usr/share/php') in /home/***/www/***.com/system/Db/Db.php on line 103" while reading response header from upstream, client: ***.**.**.**, server: ***.com, request: "GET /admin/install/ HTTP/1.1", upstream: "fastcgi://unix:/run/php/php7.0***.com.sock:", host: "***.com"

Ругается на отсутствие conf_global.php. Но что-то я не припоминаю чтобы этот файл надо было создавать при новой установке. Он вроде как во во время ее создается.

 

Но мне требуется обновление... А оно проходит без логов.

У  меня чистый nginx + php7.0-fpm без апача

 

Share this post


Link to post
Share on other sites

Из коробки конфиг поставляется в виде conf_global.dist.php. Если имеются права на запись в директорию установки, файл переименовывается автоматически в conf_global.php

2 часа назад, Azazel сказал:

Обновился. Появились сильные тормоза, google page speed снизил оценку с 82 до 72. При открытии статьи в pages ошибка скрипта. И это со стандартным шаблоном. В общем откатился назад. Сушить ее и сушить еще )

С изображениями проблем небыло. Перестроились без проблем. Лишние удалились, освободив три гб на диске.

Тему обновил? Плагины отключил? Разработчики указывали, что нужно производить обновление темы и плагинов.

Share this post


Link to post
Share on other sites

Обновился. Полёт нормальный. 

по повод страниц и собственный баз данных. посмотрите статью и если вы изменяли стандартный шаблон. 

For the most part, themes created for Invision Community 4.3 should work without modification on Invision Community 4.4. However, for sites with more heavily customized themes, there may be some manual updates you will need to make to ensure compatibility.

The document below outlines the areas you should review. We'll update the document as and when we identify particular areas that may be causing upgrade problems.

https://invisioncommunity.com/4guides/themes-and-customizations/upgrading-themes-to-44-r320/#Pages Record Templates

Share this post


Link to post
Share on other sites
2 минуты назад, Respected сказал:

Тему обновил? Плагины отключил? Разработчики указывали, что нужно производить обновление темы и плагинов.

Тему обновил, да и на дефолтной, созданной на обновленном движке проверял. А вот плагины не все отключил, но там два-три плагина, не требующих обновления, типа подсветки автора и цитирования выделенного текста. К статьям они отношения не имеют и главную не должны тормозить. Попробую еще раз через пару обновлений. Может быть поможет )

Share this post


Link to post
Share on other sites
12 минут назад, Respected сказал:

Из коробки конфиг поставляется в виде conf_global.dist.php. Если имеются права на запись в директорию установки, файл переименовывается автоматически в conf_global.php

лог говорит, что require(): Failed opening required '/home/***/www/***.com/conf_global.php' Это значит  require() не находит conf_global.php' .  Если прочитать лог дальше, то эта функция была вызвана из скрипта  /Db/Db.php . 

Вот только зачем установка вызывает эту функцию до создания файла? Для проверки возможности создания файла и прав доступа есть другие функции.

Share this post


Link to post
Share on other sites

Respected 

А вы не могли бы перепроверить выложенный тут файл на работоспособность?

Логи выше я выложил.

Failed opening required '/home/***/www/***.com/conf_global.php'

Судя по всему вместо установки запускается форум, как будто он уже установлен.

Если создать пустой файл conf_global.php, то ошибки будут примерно такого плана:

2019/02/26 17:51:18 [error] 2211#2211: *10776636 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught ErrorException: Class IPS\Request could not be loaded. Ensure it has been properly prefixed with an underscore and is in the correct namespace. in /home/***/***/init.php:429
Stack trace:
#0 [internal function]: IPS\IPS::errorHandler(256, 'Class IPS\\Reque...', '/home/***....', 429, Array)

Все это говорит о том, что скрипт пытается запуститься как уже установленный форум, а не не как установка форума.

Share this post


Link to post
Share on other sites

Truncated incorrect DOUBLE value: '' 
/home/tvu/domains/tvunderground.org.ru/public_html/forum/system/Application/Application.php::1636

UPDATE `ibf_core_sys_conf_settings` core_sys_conf_settings SET conf_value=conf_value*30 WHERE conf_key=?

Вот такая ошибка при апгрейде. Есть идеи?

 

Share this post


Link to post
Share on other sites

upd: отключаю все плагины - работает нормально.

пробую отключать по одному чтобы найти причину - не нашел.

в АЦ ловлю возле плагинов такую ошибку [Template core/admin/plugins/pluginRowDescription is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

Share this post


Link to post
Share on other sites

September^^ не тот дизайн используешь.

ясно же написано

35 минут назад, September^^ сказал:

This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.

На новом двиге форума проверять и ставить онли на дефолтном стиле.

Старые свои стили можешь забыть.

Share this post


Link to post
Share on other sites
36 минут назад, SlawkA сказал:

September^^ не тот дизайн используешь.

ясно же написано

На новом двиге форума проверять и ставить онли на дефолтном стиле.

Старые свои стили можешь забыть.

Да и на дефолте не лучше. 

 

Share this post


Link to post
Share on other sites

Error: Call to a member function getTerm() on null (0)
#0 /var/www/hpp.ovh/system/Node/Controller.php(413): IPS\nexus\Subscription\_Package->formatFormValues(Array)
#1 /var/www/hpp.ovh/system/Dispatcher/Controller.php(85): IPS\Node\_Controller->form()
#2 /var/www/hpp.ovh/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#3 /var/www/hpp.ovh/applications/nexus/modules/admin/subscriptions/subscriptions.php(54): IPS\Node\_Controller->execute()
#4 /var/www/hpp.ovh/system/Dispatcher/Dispatcher.php(152): IPS\nexus\modules\admin\subscriptions\_subscriptions->execute()
#5 /var/www/hpp.ovh/admin/index.php(14): IPS\_Dispatcher->run()
#6 {main}

OutOfRangeException:  (0)
#0 /var/www/hpp.ovh/system/Content/Item.php(1149): IPS\Patterns\_ActiveRecord::load(3)
#1 /var/www/hpp.ovh/system/Content/Item.php(2250): IPS\Content\_Item->container()
#2 /var/www/hpp.ovh/applications/nexus/sources/Package/Item.php(158): IPS\Content\_Item->delete()
#3 /var/www/hpp.ovh/applications/nexus/sources/Package/Package.php(229): IPS\nexus\Package\_Item->delete()
#4 /var/www/hpp.ovh/applications/core/extensions/core/Queue/DeleteOrMoveContent.php(41): IPS\nexus\_Package->delete()
#5 /var/www/hpp.ovh/system/Task/Task.php(134): IPS\core\extensions\core\Queue\_DeleteOrMoveContent->preQueueData(Array)
#6 /var/www/hpp.ovh/system/Node/Model.php(3242): IPS\_Task::queue('core', 'DeleteOrMoveCon...', Array)
#7 /var/www/hpp.ovh/system/Node/Controller.php(1246): IPS\Node\_Model->deleteOrMoveFormSubmit(Array)
#8 /var/www/hpp.ovh/applications/nexus/modules/admin/store/packages.php(128): IPS\Node\_Controller->delete()
#9 /var/www/hpp.ovh/system/Dispatcher/Controller.php(85): IPS\nexus\modules\admin\store\_packages->delete()
#10 /var/www/hpp.ovh/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#11 /var/www/hpp.ovh/applications/nexus/modules/admin/store/packages.php(40): IPS\Node\_Controller->execute()
#12 /var/www/hpp.ovh/system/Dispatcher/Dispatcher.php(152): IPS\nexus\modules\admin\store\_packages->execute()
#13 /var/www/hpp.ovh/admin/index.php(14): IPS\_Dispatcher->run()
#14 {main}

Магазин короче еще кривой))

Share this post


Link to post
Share on other sites
11 минут назад, zxcoikio сказал:

Error: Call to a member function getTerm() on null (0)
#0 /var/www/hpp.ovh/system/Node/Controller.php(413): IPS\nexus\Subscription\_Package->formatFormValues(Array)
#1 /var/www/hpp.ovh/system/Dispatcher/Controller.php(85): IPS\Node\_Controller->form()
#2 /var/www/hpp.ovh/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#3 /var/www/hpp.ovh/applications/nexus/modules/admin/subscriptions/subscriptions.php(54): IPS\Node\_Controller->execute()
#4 /var/www/hpp.ovh/system/Dispatcher/Dispatcher.php(152): IPS\nexus\modules\admin\subscriptions\_subscriptions->execute()
#5 /var/www/hpp.ovh/admin/index.php(14): IPS\_Dispatcher->run()
#6 {main}

OutOfRangeException:  (0)
#0 /var/www/hpp.ovh/system/Content/Item.php(1149): IPS\Patterns\_ActiveRecord::load(3)
#1 /var/www/hpp.ovh/system/Content/Item.php(2250): IPS\Content\_Item->container()
#2 /var/www/hpp.ovh/applications/nexus/sources/Package/Item.php(158): IPS\Content\_Item->delete()
#3 /var/www/hpp.ovh/applications/nexus/sources/Package/Package.php(229): IPS\nexus\Package\_Item->delete()
#4 /var/www/hpp.ovh/applications/core/extensions/core/Queue/DeleteOrMoveContent.php(41): IPS\nexus\_Package->delete()
#5 /var/www/hpp.ovh/system/Task/Task.php(134): IPS\core\extensions\core\Queue\_DeleteOrMoveContent->preQueueData(Array)
#6 /var/www/hpp.ovh/system/Node/Model.php(3242): IPS\_Task::queue('core', 'DeleteOrMoveCon...', Array)
#7 /var/www/hpp.ovh/system/Node/Controller.php(1246): IPS\Node\_Model->deleteOrMoveFormSubmit(Array)
#8 /var/www/hpp.ovh/applications/nexus/modules/admin/store/packages.php(128): IPS\Node\_Controller->delete()
#9 /var/www/hpp.ovh/system/Dispatcher/Controller.php(85): IPS\nexus\modules\admin\store\_packages->delete()
#10 /var/www/hpp.ovh/system/Node/Controller.php(62): IPS\Dispatcher\_Controller->execute()
#11 /var/www/hpp.ovh/applications/nexus/modules/admin/store/packages.php(40): IPS\Node\_Controller->execute()
#12 /var/www/hpp.ovh/system/Dispatcher/Dispatcher.php(152): IPS\nexus\modules\admin\store\_packages->execute()
#13 /var/www/hpp.ovh/admin/index.php(14): IPS\_Dispatcher->run()
#14 {main}

Магазин короче еще кривой))

 

посмотри тему мою чуть ранее, у меня такие же ошибки)

думаю стоит немного подождать, ну либо хз. Я пока откатился

Share this post


Link to post
Share on other sites
2 минуты назад, September^^ сказал:

 

посмотри тему мою чуть ранее, у меня такие же ошибки)

думаю стоит немного подождать, ну либо хз. Я пока откатился

это не критично для меня, да и 502 ловил ты потому что надо fastcgi кеш увеличить

Share this post


Link to post
Share on other sites
53 минуты назад, eremini сказал:

Можно обновить до посленего билда?

Можно обновляться. 

33 минуты назад, olegg сказал:

Подскажите как убрать назойливое уведомление о наличии новой версии? спасибо.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×