Jump to content

Get Ready For IPS 4.0!


RSS Bot
 Share

Recommended Posts

IPS Community Suite 4.0, the most significant update to IP.Board and the rest of our apps we've ever made, is fast approaching a state where we'll be ready for a public preview and, soon after that, public beta testing!
 
We know most of you are just as excited as we are about this and can't wait to try it out.
 
With 4.0, we've made some significant leaps in terms of modernization, and it's possible that you might need to do some preparation before you're ready to install it. Notably, our minimum PHP and MySQL versions have gone up. It's the first time we've needed you to do this in 6 years, and the versions we need you to have have been around for a long time, we're not requiring the latest versions.
 
In addition, 4.0 is UTF-8 only (if you don't know what that is, it's a way text can be stored in your database which you may or may not be using at the moment) and while the 4.0 upgrade process will convert your database for you if you're not already using it, this is a moderately time-consuming process, so if you convert your database now, it's one less thing to worry about on upgrade day.
 
 
To make this process as easy as possible, we have created a little script which you can upload to your server to test if you're ready.

Читать дальше

 

Файл обновлён 29 июля в 00:00

ips4.php.zip

Link to comment
Share on other sites

написал хостеру запрос на апгрейд :( 

 

 

You are running MySQL version 5.5.36-cll-lve. While this version is compatible, we recommend version 5.6.0 or above. You may wish to contact your hosting provider or system administrator to ask for an upgrade.

You are running PHP version 5.3.27. While this version is compatible, we recommend version 5.4.0 or above. You may wish to contact your hosting provider or system administrator to ask for an upgrade. 

Link to comment
Share on other sites

You are running MySQL version 5.5.36-cll-lve

У тебя хоть довольно новая версия. Не то, что на Джино:

You are running MySQL version 5.1.49-rel11.3-log. While this version is compatible, we recommend version 5.6.0 or above. You may wish to contact your hosting provider or system administrator to ask for an upgrade.

Link to comment
Share on other sites


У тебя хоть довольно новая версия.

ответ хостера
 

 

 

Добрый день.

Сервер с PHP 5.4 у нас есть, а вот с mysql 5.6, к сожалению, нет, так как клиентам еще ни разу не был нужен. Запланируем создание сервера с нужной версий mysql на ближайшее время и уведомим Вас о возможности переноса.

Link to comment
Share on other sites


ответ хостера

IPB40 не нужна такая версия сервака. Они там беленов объелись как всегда.

Link to comment
Share on other sites

IPB40 не нужна такая версия сервака. Они там беленов объелись как всегда.

 

Боюсь хостер повысит версии раньше, чем IPS выпустят четверку...  :facepalm:

Link to comment
Share on other sites

IPB40 не нужна такая версия сервака. Они там беленов объелись как всегда.

Ничего они не объелись. Минимальная версия 5.0.3 - должна быть уже у всех. А 5.6 - это просто рекомендуемая, ничего более.

На официальном сайте MySQL сказано: MySQL 5.6: Up to 230% Faster! Т.е если будет стоять 5.6, то IPS будет работать быстрее.

Link to comment
Share on other sites

странно но выдает
 

Some or all of the columns in your database are not using the utf8_unicode_ci collation (ipb_admin_login_logs.admin_ip_address is utf8_general_ci).

 

Link to comment
Share on other sites

У нас здесь такая же ситуация, на другом сервере всё в порядке. Мне кажется не стоит обращать внимания на эту надпись, пока не вышел релиз. 

Link to comment
Share on other sites

Respected,

У меня то же самое. Это скорее всего из за установленных приложений и хуков, добавляющих запись в БД 

Link to comment
Share on other sites

AUS, по всей видимости, разработчики жестко требуют uft8_unicode_ci и не приемлют utf8_general_ci, что довольно странно. Особенно в свете того, что по умолчанию форум при установке вообще не задавал нужную себе кодировку, в итоге у всех COLLATE разный.

Link to comment
Share on other sites

У нас здесь такая же ситуация, на другом сервере всё в порядке. Мне кажется не стоит обращать внимания на эту надпись, пока не вышел релиз. 

 

Я так понимаю речь идет об одной конкретной табличке

 

 

ipb_admin_login_logs.admin_ip_address

 

возможно какой-то хук её создал... 

 

хотя вопрос есть ли она вообще...

post-8414-0-87374600-1402907636.jpg

оказывается это столбец в таблице а не сама таблица... странно я думал кодировка устанавливается ко всей базе, а не к конкретным таблицам

 

post-8414-0-80664600-1402907968.jpg

Link to comment
Share on other sites

Я так понимаю речь идет об одной конкретной табличке

В 9-ом сообщении написано.

 

возможно какой-то хук её создал...

Ни какой.

 

хотя вопрос есть ли она вообще...

Есть. Самая первая в списке.

ipb_admin_login_logs.admin_ip_address

Название таблицы

Название поля

Link to comment
Share on other sites

форум при установке вообще не задавал нужную себе кодировку

Не путайте кодировку и сравнение. Это совершенно разные вещи

Link to comment
Share on other sites

Необходимо скачать php файл и поместить в корень форума. Затем перейти в браузере сайт.ру/ips4.php

Link to comment
Share on other sites

Sufiy, используйте этот файл, он на русском и не собирает информацию о лицензии '?do=embed' frameborder='0' data-embedContent>>

Link to comment
Share on other sites

  • 2 weeks later...


 

	
		PHP Requirements
	
	You are running PHP version 5.3.13. While this version is compatible, we recommend version 5.4.0 or above. You may wish to contact your hosting provider or system administrator to ask for an upgrade.
	cURL extension loaded
	DOM extension loaded.
	GD extension loaded.
	Multibyte String extension loaded.
	MySQLi extension loaded.
	OpenSSL extension loaded.
	Session extension loaded.
	SimpleXML extension loaded.
	XML Parser extension loaded.
	XMLReader extension loaded.
	XMLWriter extension loaded.
	Zip extension loaded.
	128M memory limit.
	No Suhosin restrictions.
	


	
		MySQL Requirements
	
	MySQL connection could not be established to perform version check. Make sure your MySQL Server version is 5.0.3 or above (5.6.0 or above recommended).
	

Как пхп обновить и мускул обновить, шоп все не слетело? Версия мускула 5.1.40... Сссылки скиньте, если не сложно. Или проще заново веб-сервер собрать?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Ваша ссылка была автоматически строена.   Отображать как обычную ссылку

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...